cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 6 MCU

New Contributor II

Hi,

I get following error message when trying to build the project:

The given PDL path '' is invalid. Unable to find required PDSC file.

What does this mean and how to fix it?

0 Likes
Reply
1 Solution
Moderator
Moderator

Hi ViTi_1549261​,

Please click on Tools > Options and share screenshot of the window that appears.

What is the location in PDL v3 (PSoC 6 devices) location:? Please try setting this to

C:\Program Files (x86)\Cypress\PDL\3.1.x

where x stands for the PDL version that you have installed in your PC.

Please let me know if this works.

Thanks and Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B

View solution in original post

0 Likes
Reply
5 Replies
Moderator
Moderator

Hi ViTi_1549261​,

Please click on Tools > Options and share screenshot of the window that appears.

What is the location in PDL v3 (PSoC 6 devices) location:? Please try setting this to

C:\Program Files (x86)\Cypress\PDL\3.1.x

where x stands for the PDL version that you have installed in your PC.

Please let me know if this works.

Thanks and Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B

View solution in original post

0 Likes
Reply
New Contributor II

pastedImage_0.png

These two boxes were empty, but I selected the path that you suggested and now I am able to go forward.

My next problem was following message on PSoC creator output window:

--------------- Build Succeeded: 11/09/2020 17:28:02 ---------------

KitProg version Expecting 2.21, but found 2.18. Please use PSoC Programmer GUI to upgrade firmware.

Warning: dbg.M0039: There was an error running port acquire:

Do you have suggestion to fix this?

0 Likes
Reply
Moderator
Moderator

Hi ViTi_1549261,

KitProg version Expecting 2.21, but found 2.18. Please use PSoC Programmer GUI to upgrade firmware.

Please connect the device to PSoC Programmer and update the firmware? You can refer to this thread - Re: Prog version Expecting 2.21, but found 2.19. Please use PSoC Programmer GUI to upgrade firmware ...

Warning: dbg.M0039: There was an error running port acquire:

Please verify the port settings and ensure that they correct. If the settings are correct, please try connecting to the device using PSoC Programmer and perform a Read to log action and let me know if that works.

Thanks and Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B
0 Likes
Reply
New Contributor II

Hi,

in PSoC Programmer the "Upgrade Firmware" button is disabled.

pastedImage_0.png

0 Likes
Reply
Moderator
Moderator

Hi ViTi_1549261,

I believe the KitProg is in Mass Storage Programmer Mode. Please refer to the below screenshot to exit from Mass Storage Programmer Mode -

pastedImage_0.png

You can find this information in KitProg User Guide. Please let me know if this helps.

Thanks and Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B
0 Likes
Reply
Top labels