cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 6 MCU

AaSi_4486746
New Contributor

I tried to connect the board CY8CPROTO-064S1-SB with ModusToolbox IDE 2.1

But the BSP for CY8CPROTO-064S1-SB is unavailable.

please find the screenshot for the issue below:

P.S. As per the discussion in the community, find the link here: https://community.cypress.com/thread/53959

It was mentioned to use ModusToolbox IDE for PSoC64 device.

NO_BSP_FOR_CY8CPROTO-064S1-SB.png

Could you help me solve this issue.

Aadarsh Kumar Singh

0 Likes
Reply
1 Solution
Rakshith
Moderator
Moderator

Hi AaSi_4486746​,

Yes, that is correct. There is currently no support for PSoC 64 devices on ModusToolbox. This was the reason I asked for details regarding the source of your PSoC 64 device. From your post on the thread - Re: How to create new PSoc Creator 4.2 project with CY8CPROTO-064S1-SB prototyping kit,​ I got to know that you got the CY8CPROTO-064S1-SB Kit from Hochschule Darmstadt University for a project. Can you please provide more details regarding the project and the entire program through which you received the Kit?

We will be supporting PSoC 64 devices soon. Please stay tuned for that. But for now, you can use mbedOS for developing applications on PSoC 64. You can learn more about it here - MBED OS 5.14 RELEASED WITH PSOC 64 SECURE MCU SUPPORT

Hope this helps,

Thanks and Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B

View solution in original post

0 Likes
Reply
1 Reply
Rakshith
Moderator
Moderator

Hi AaSi_4486746​,

Yes, that is correct. There is currently no support for PSoC 64 devices on ModusToolbox. This was the reason I asked for details regarding the source of your PSoC 64 device. From your post on the thread - Re: How to create new PSoc Creator 4.2 project with CY8CPROTO-064S1-SB prototyping kit,​ I got to know that you got the CY8CPROTO-064S1-SB Kit from Hochschule Darmstadt University for a project. Can you please provide more details regarding the project and the entire program through which you received the Kit?

We will be supporting PSoC 64 devices soon. Please stay tuned for that. But for now, you can use mbedOS for developing applications on PSoC 64. You can learn more about it here - MBED OS 5.14 RELEASED WITH PSOC 64 SECURE MCU SUPPORT

Hope this helps,

Thanks and Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B

View solution in original post

0 Likes
Reply
Top labels