cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 6 MCU

GePa_4776901
New Contributor

 

I'm trying to program a Psoc6 using "Cypress Programmer 3.0". 

When I try this software with a PROTO-062-4343W it works fine, but on my board, it doesn't. My board has a different MCU.

After I connect the KitProg3 to my board. I do a "Reload Regions" to eliminate some of the errors. I can do a "Verify" and it works fine (effectively find differences or success if I change the file).. but when I do "Program" I get this errors:

Info : cyp status: OK

Info : ** Verified OK **

Info : cyp_get_mpn

Info : ** Detected device PN: CY8C6247BZI-D54 SiliconID: E206 Revision: 23 FamilyID: 100 DIE: PSoC6ABLE2

Info : program_device "/Debug/mtb-example-psoc6-hello-world.hex" "0"

Info : ** Program image /Debug/mtb-example-psoc6-hello-world.hex offset:0 **

Info : kitprog3: acquiring PSoC device...

Info : target halted due to debug-request, current mode: Thread

Info : xPSR: 0x01000000 pc: 0x00001f34 msp: 0x080477a8

Info : ** Device acquired successfully

Info : ** psoc6.cpu.cm4: Ran after reset and before halt...

Info : target halted due to debug-request, current mode: Thread

Info : xPSR: 0x61000000 pc: 0x1600400c msp: 00000000

Info : ** Programming Started **

Info : auto erase enabled

Info : Flash write discontinued at 0x10001894, next section at 0x10002000

Info : Padding image section 0 at 0x10001894 with 364 bytes (bank write end alignment)

Info : [ 53%] [################ ] [ Erasing ]timeout waiting for algorithm, a target reset is recommended

Info : SROM API execution failed. Status: 0x080008B4

Info : failed erasing sectors 0 to 12

Error: cyp status: ERROR

Info : Program device failed

Error: C:/Program Files (x86)/Cypress/Cypress Programmer 3.0/./scripts/cyp_base_default.tcl:38: Error: ** Programming Failed **

Error: in procedure 'program_device'

Error: at file "C:/Program Files (x86)/Cypress/Cypress Programmer 3.0/./scripts/cyp_base_default.tcl", line 38

Info : cyp_get_mpn

Info : ** Detected device PN: CY8C6247BZI-D54 SiliconID: E206 Revision: 23 FamilyID: 100 DIE: PSoC6ABLE2

 

Seems like an error on a script:

scripts/cyp_base_default.tcl", line 38

 

If I use ModusToolbox, I'm able to program my device with no problems... I just want to use "Cypress Programmer" so that someone else can program my boards without needing the source code and having ModusToolbox.

 

Thanks!

0 Likes
1 Solution
Rakshith
Moderator
Moderator

Hi @GePa_4776901

I tried programming the hexfile to CY8CKIT-062-WiFi-BT Kit which has the same device and I was able to program the device successfully and the blue LED turned on after programming. The Cypress Programmer log for your reference - 

Rakshith_0-1619114664103.png

Can you please let me know the programming parameters used to program your custom board? Also, do you have access to the CY8CKIT-062-WiFi-BT Kit or MiniProg4? If so, can you please let me know if programming the Kit or programming using MiniProg4 works successfully? 
Which ModusToolbox version are you using? This will help me with the OpenOCD version that is used. Can you also provide the schematic of the power and programming pins for reference?

Thanks and Regards,
Rakshith M B

View solution in original post

0 Likes
3 Replies
Rakshith
Moderator
Moderator

Hi @GePa_4776901

We generally see this error/issue when the hexfile does not match the device selected. Can you please confirm that the hexfile is for the CY8C6247BZI-D54 device? If so, would it be possible for you to share the hexfile on this thread so that we can try and recreate the issue?

Thanks and Regards,
Rakshith M B
0 Likes
GePa_4776901
New Contributor

 

Thanks Rakshith.

I'm pretty sure the hex file is for that device. Proof of that is:

1. It works if I program it with ModusToolbox

2. After I program it with Modus Toolbox, I can do a Verify, and I don't get any errors (if I change the file, it does notice that is different).

3. I've tried all the different programs hex files I have done for that board, and get the same kind of error.

I'm attaching the hex file.

 

Thanks!

0 Likes
Rakshith
Moderator
Moderator

Hi @GePa_4776901

I tried programming the hexfile to CY8CKIT-062-WiFi-BT Kit which has the same device and I was able to program the device successfully and the blue LED turned on after programming. The Cypress Programmer log for your reference - 

Rakshith_0-1619114664103.png

Can you please let me know the programming parameters used to program your custom board? Also, do you have access to the CY8CKIT-062-WiFi-BT Kit or MiniProg4? If so, can you please let me know if programming the Kit or programming using MiniProg4 works successfully? 
Which ModusToolbox version are you using? This will help me with the OpenOCD version that is used. Can you also provide the schematic of the power and programming pins for reference?

Thanks and Regards,
Rakshith M B

View solution in original post

0 Likes
Top labels