cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 6 MCU

Gintaras
New Contributor II

Hi,

I have successfully created my own BSP in ModusToolbox.

But when I tried to add custom memory configuration using QSPI Configurator tool I faced the issue: The new project is created and even built successfully with custom BSP on other PC, but if I open the QSPI Configurator it throws the error that  APS6404L-3SQR-ZR.cymem file is empty. And I have to re select the file and configure all the memories all over again.

So what wold be correct way to include the *.cymem files into the custom BSP project?

I have attached the Custom BSP project (it is for CY8C6245AZI-S3D72 custom board)

0 Likes
1 Solution
DheerajK_81
Moderator
Moderator

Hello @Gintaras ,

I'm able to reproduce this issue at my end. I feel the error is a false positive. I will check why this error occurs even though the file format is valid and not empty. 

When the error is thrown, just click Ok. Then click on the Slot > Scroll down the list of memory devices to the end where "<browse>" option is seen > Point to your .cymem file and click Open.  It should be loaded with all the parameters as shown below:

DheerajK_81_0-1616762745832.png

Meanwhile, please check this workaround and let me know if it works for you as well.

Regards,
Dheeraj

 

View solution in original post

0 Likes
3 Replies
DheerajK_81
Moderator
Moderator

Hello @Gintaras ,

I'm able to reproduce this issue at my end. I feel the error is a false positive. I will check why this error occurs even though the file format is valid and not empty. 

When the error is thrown, just click Ok. Then click on the Slot > Scroll down the list of memory devices to the end where "<browse>" option is seen > Point to your .cymem file and click Open.  It should be loaded with all the parameters as shown below:

DheerajK_81_0-1616762745832.png

Meanwhile, please check this workaround and let me know if it works for you as well.

Regards,
Dheeraj

 

View solution in original post

0 Likes
Gintaras
New Contributor II

Hi Dheeraj,

Yes, I already know that only by re-selecting it manually it does not throw error anymore. But this workaround will not be obvious for a new user.

Regards,

Gintaras

0 Likes
DheerajK_81
Moderator
Moderator

Hello @Gintaras ,

Yes that's right. The intention was always to load it on startup. We should not be re-selecting manually again. I will pass this on to the software team for evaluation. 

Please use this workaround to move forward until this is fixed.

Regards,
Dheeraj

0 Likes
Top labels