cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 6 MCU

Anonymous
Not applicable

Hello,

I am using PSoC6 BLR Pioneer Kit, and I want to use on board 32MHz xtal with ECO.

I set "Configure System Clocks" as below.

  ECO :32MHz, 100uW, 80phm, 8pF, 10ppm

But my blinking program did not work.

Then, I changed PLL source from ECO to IMO, it  worked well.

I observed the xtal waveform with an oscilloscope, but it did not oscillate.

so can anyone help in this matter?

Thanks,

0 Likes
1 Solution
ShipingW_81
Moderator
Moderator

This is just because there is no ECO mounted on the kit board. There is only BLE ECO mounted. You can select the AltHF: BLE ECO instead, which can be routed for system use. Generally, if BLE used in your project, BLE ECO is mandatory and ECO can be omitted on your board.

View solution in original post

4 Replies
RodolfoGL
Employee

Can you take a screenshot of the clock configuration you setup in PSoC Creator?

Anonymous
Not applicable

Thank you for your prompt reply.

>Can you take a screenshot of the clock configuration you setup in PSoC Creator?

My setting is below.

Thanks,

eco setting.bmp

0 Likes
ShipingW_81
Moderator
Moderator

This is just because there is no ECO mounted on the kit board. There is only BLE ECO mounted. You can select the AltHF: BLE ECO instead, which can be routed for system use. Generally, if BLE used in your project, BLE ECO is mandatory and ECO can be omitted on your board.

View solution in original post

Anonymous
Not applicable

> There is only BLE ECO mounted. You can select the AltHF: BLE ECO instead

->I understand.

    My problem is resolved.

Thanks,

0 Likes
Top labels