cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 6 MCU

QiLu_3389441
New Contributor

Hi,

   I just try to test the I2C followed the step of PSoC 6 101: Lesson 2-3a Basic I2C Implementation.

   In the panel, I just can see the com port, but no Kitprog2 on the list.

   I check the manual, there is the introduction of The KitProg2 can function as a USB-I2C bridge, so it supposes to work.

   What's the problem?

0 Likes
Reply
1 Solution
ShipingW_81
Moderator
Moderator

It looks the kitprog2 port is not shown in control panel port list. Please check the device manager in your platform whether kitprog2 is shown, just like attached capture(under 'Ports' list).

If not shown, please check if the correct mode is on by SW3 on the board.Capture_kitprog.PNG

View solution in original post

0 Likes
Reply
4 Replies
ShipingW_81
Moderator
Moderator

Hello,

Please make sure you have select the 'Protocol' as 'I2C' in the control panel GUI. otherwise, I2C interface would not show.

0 Likes
Reply
QiLu_3389441
New Contributor

Hi,

   But the protocol I2C is not selectable, thx

0 Likes
Reply
ShipingW_81
Moderator
Moderator

It looks the kitprog2 port is not shown in control panel port list. Please check the device manager in your platform whether kitprog2 is shown, just like attached capture(under 'Ports' list).

If not shown, please check if the correct mode is on by SW3 on the board.Capture_kitprog.PNG

View solution in original post

0 Likes
Reply
QiLu_3389441
New Contributor

Hi, the problem is the SW3, thx

0 Likes
Reply
Top labels