cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

New Contributor II

 Hi Everyone,

   

I have modified a CY8Ckit-031 demonstration program to use the slider and CS buttons on the -030 board in addition to those in the original demo and am now chasing my tail.

   

The original demo program is called SLM_I2C_Tuner_Kit-030. I have the 5 button, 5 LED, 10 element slider board plugged into the 44/40 pin adapter and the adapter plugged into the -030 PORT E. In TopDesign, I've added 2 control bits, and 2 LEDs (no additional inverters as the -030 LEDs are tied to ground while the -031 LEDs are tied to Vdd). The capsense component now has 7 buttons and 2 sliders ( a 10 element and a 5 element slider).  I changed the main.c file to have 7 buttons and 7 LEDs. I enabled the tuner, tuned, validated and saved the Capsense baseline data and disabled the tuner. I did a clean and build followed by programming the device.

   

Button0 does not light up the first LED, it lights the second instead. In fact all the buttons light the next LED up instead of the one intended. the last button does not light any LED. AND ... this is why I think I have a Capsense problem ... touching any element of the -030 board's slider will light up the first LED (the one that should have lit for button0. The slider on the SLM module does act as expected and lights the 7 LEDs as expected in sequence based on the position on the 10 element slider, including the first LED and the 6th and 7th LEDs.

   

Nothing is Di-plexed. Is that needed when I go over 20 sensors? I have yet to use the position info from the 5 element slider on the -030 board. Except for the number of buttons and LEDs defined, I have not changed how the left shift code works.in main.c.

   

I will try eliminating two slider sensors to get down to 20 total next.

   

Please let me know if you see that I have done simethng obviously wrong or you can help solve my mystery.

   

Thanks very much

   

Tim Miner

0 Likes
Reply
3 Replies
Anonymous
Not applicable

 Hi Tim,

   

It does not need diplexing. Diplexing is when you need to save number of pins and also diplexing requires different board design. In your case, it looks like firmware bug where lights are not indicated properly. Can you check if all buttons and siders are working properly by connecting Tuner GUI ? Can you also attach your project in the forum ? You can use minimal option in Creator to archive project so that file size is small. 

0 Likes
Reply
Esteemed Contributor

o post your project -

   

 

   

“File”                                                             Creator

   

“Create Workspace Bundle”

   

Use Firefox or IE or chrome to post.

   

 

   

 

   

Regards, Dana.

0 Likes
Reply
New Contributor II

 attaching an archive of the workspace buldle ...

   

Note that while using the tuner, all buttons and sliders seemed to work... though, the firmware offset that is my problem, was still present.  If I eliminate the second slider, the problem goes away.

   

 

   

regards

   

Tim Miner

0 Likes
Reply