cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

Anonymous
Not applicable

hi to all,

   

             how can i  set reference voltage for ADC in psoc1. here i want to set reference voltage 2.5v.

   

thanks

   

PRP

0 Likes
Reply
1 Solution
Esteemed Contributor

Also look in TRM (Technical Reference Manual) for your device to get a better

   

understanding of the Ref system.

   

 

   

Regards, Dana.

View solution in original post

0 Likes
Reply
44 Replies
Esteemed Contributor

I do not see any obvious errors. Consider posting a CASE so that internal

   

engineer can replicate your HW. I do not have this HW to debug.

   

 

   

Some questions / observations -

   

 

   

1) Set your OpAmp bias in Global resources window (upper left window) to high as that affects

   

CM range of PGA,

   

 

   

2) Are the two inputs not giving correct answer subject to 50/60 Hz pickup ?

   

Are they coming from hi z sources taht would be subject to pickup, stray coupling ?

   

 

   

Regards, Dana.

0 Likes
Reply
Anonymous
Not applicable

 Hi Bob, Dana

   

I'm using P0.2, P0.3, P0.4 (PSoC1 CY8C24123); 3 that pin would be configure as Analog Input (CY8C24123 datasheet).

   

About details problem:

   

- First, I set voltage to 3 pins P0.2, P0.3, P0.4 ( P0.2: 0V, connect GND when i test; P0.3: 4,5V ; P0.4: 0V , connect GND when i test).

   

-When I run lastest project, voltage on 3 pin:

   

P0.2 : 0.05V

   

P0.3: 0.05V

   

P0.4: 0.05V

   

Values are not correct!(I'm using ADCINCVR, PGA,AMUX8,TX8). Voltage on 3 pin is similar(equals)!

   

ADCINCVR, PGA: measure 0-5V

   

AMUX8: select pin AnalogInput to PGA,ADCINCVR

   

TX8: send data to PC

   

About:

   

"1) Set your OpAmp bias in Global resources window (upper left window) to high as that affects

   

 

   

CM range of PGA," I want measure voltage range: 0-5V.

   

I refer: http://www.cypress.com/?id=4&rID=58573

   

 

   

 

   

"2) Are the two inputs not giving correct answer subject to 50/60 Hz pickup ?

   

Are they coming from hi z sources taht would be subject to pickup, stray coupling ?"

   

Does Dana want ask me about signal input that I'm using? Signal input is DC, not 50/60Hz.

   

I think I configured ADCINCVR, PGA not correct?

   

Many thanks.

0 Likes
Reply
Esteemed Contributor II

I took your last project archive and the ports I mentioned were not configured as inputs.

   

So where do we differ?

   

Did I take the wrong project

   

Did you post the wrong project

   

Did you overlook the error I am talking about?

   

You ARE using pin 2,3,4 and 6 of Port0

   

 

   

Bob

0 Likes
Reply
Esteemed Contributor

Based on code and prior he is only looking at 3 pins, and they are setup

   

properly.

   

 

   

@cxcttmm, tie the three pins together and feed them with a known DC voltage, like

   

Vdd/2. generated from two equal Rs external.

   

 

   

I still recommend you file a Case so Cypress EE can fire up HW and look at this

   

problem. Makes me wonder if its a problem with AMUX8 in a two adjacent column

   

part.

   

 

   

Regards, Dana.

0 Likes
Reply
Anonymous
Not applicable

Hi Bob, Dana

   

I'll check my project again.

   

@Dana: I created a case (Technical Support ) but I haven't been received any answers about using AMUX8/AMUX4 from technical person.

   

Thanks!

0 Likes
Reply