cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

Anonymous
Not applicable

I have been trying to get a better data save rate for a recorder that I am working on.

   

I have the data collection side working, but not seeing a high enough transfer rate on the save side.

   

I am using the emFile component, and running on a Psoc3.

   

 

   

I am able to test with the software built as a debug version.

   

When I try to generate the software as "release" code, the build complains about "FS_USE_PARA".

   

Changing the software to get around the  "FS_USE_PARA" problem, then gives other errors... like the component is not setup for release build. I get the same errors if I test with the example code for the emFile component.

   

 

   

Do I need to add the component into another area for the release build to work?

   

Thanks.

0 Likes
Reply
2 Replies
Esteemed Contributor

Post your project -

   

 

   

    

   

          

   

"File"                      Creator

   

"Create Workspace Bundle"

   

Use Internet Explorer or Firefox to post, Chrome does not seem to work.

   

 

   

Regards, Dana.

0 Likes
Reply
Anonymous
Not applicable

Not thinking clearly on a sunday night...

   

Adding the emFile include & lib files in the build settings needs to be done for the debug and release configurations.

   

 

   

The problem I was having with the release build has been fixed after adding the emFile settings into the release configuration.

   

 

   

Thanks.

0 Likes
Reply