cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

DHolden
New Contributor

I am trying to update the firmware in some devices, but when ever I plug in the miniprog3 into my Computer, I get the USB not recognized error in windows.  If I reboot, or let it sit unplugged for a while (sometimes hours) it might work, but then will fail when I go to turn on the units power., which then tells me to disconnect the USB again to fix the issue.  This causes the whole cycle to begin again.

Anyone have any advice on how to get this to work?

0 Likes
17 Replies
Krupashankar
Moderator
Moderator

Hi @DHolden ,

Driver may not be properly installed in your system , Can you please tell which software you are using?

Please try binding the driver manually in the device manager, please refer to the document to perform manual binding of driver.

https://www.cypress.com/comment/313281

Please check if it solves your issue.

Thanks,

Krupashankar

0 Likes
DHolden
New Contributor

Using the instructions provided in the links, I manually tried both of the driver options for miniprog3 (3.4.1.20) and miniprog3 (unconfigured) and both gave me an unknown error still.  Upon opening the details of the device, it just says

This device cannot start. (Code 10)

A request for the USB device descriptor failed.

0 Likes
Krupashankar
Moderator
Moderator

Hi @DHolden ,

Can you please refer to this KBA for further troubleshooting and please check if this helps

https://community.cypress.com/t5/Knowledge-Base-Articles/Troubleshooting-PSoC-3-4-5LP-Programming-De...

You can also refer to this thread 

https://community.cypress.com/t5/PSoC-4-MCU/miniProg3/m-p/241439

 

Thanks,

Krupashankar

0 Likes
DHolden
New Contributor

I tried the MiniProg3 this morning and it worked fine for 1 program cycle, then the software stopped working, saying the power was disconnected even though nothing had changed.  I went through all linked articles and none of them offer any help that I have not tried.  MiniProg still says it is unable to start when plugged in.

0 Likes
Krupashankar
Moderator
Moderator

Hi @DHolden ,

If you have any other MiniProg3 can you please try that once?

If you are using some custom board please try with different ones and if you have any evaluation board please try programming it with MiniProg3 to find the cause of issue.

Please let us know the status of LED in MiniProg3 when the error happens.

 

Krupashankar_0-1631638398715.png

https://www.cypress.com/file/44091/download

 

Thanks,

Krupashankar

0 Likes
DHolden
New Contributor

I don't have another miniprog3.

When it says device not found, there are no LED's lit up on the MiniProg3.  

I tried a different cable, different computer, Different operating system and removed any USB hubs from the system.

It will work if I try again after several hours, but disconnects randomly during a program cycle.  For example it worked today once, but when I went to check the checksum, it would't work anymore

0 Likes
Krupashankar
Moderator
Moderator

Hi @DHolden ,

Can you please share details of PSoC device you are using, its Part number and  which software you are using to program?

Can you please confirm if issue happens during debugging or even during programming in release mode?

Are you using custom board or any evaluation board?

Please provide these details for our further support.

 

Thanks,

Krupashankar

0 Likes
DHolden
New Contributor

Software is PsoC Programmer 3.29.1 
Windows 10 System, though I have tried on Windows 7 also.

Programming a Cy8c29446 12PVXE

0 Likes
Krupashankar
Moderator
Moderator

Hi @DHolden ,

Is MiniProg3 working fine before connecting to your custom board ? Is all the status led glowing (Red- Power Green - USB detection ) before connecting your custom board?

Can you please try the option "Toggle the Power" on Programmer and tell us your observation after that?

Can you please tell how the board is powered if it is externally powered try reducing the voltage to 4.9V to 5V?

Is voltage levels chosen properly between MiniProg3 and custom board?

If MiniProg3 is working fine before connecting to custom board, can you please share schematics section MiniProg3 connector of your custom board and pins associated with it?

Can you please share which programming protocol , programming mode you are using and PSoC programmer tool  screenshot?

 

Thanks,

Krupashankar

0 Likes
DHolden
New Contributor

The issue happens as soon as I plug in the MiniProg3 into the USB port.  The sequence I was instructed to follow was

1. Open PSoC Programmer software

2. Plug in MiniProg3 programmer

 

But every time I plug in the programmer it comes up with unknown device.  I have uninstalled and reinstalled the software multiple times and it doesn't fix the issue

0 Likes
Krupashankar
Moderator
Moderator

Hi @DHolden ,

Can you please check if any of the MiniProg3 pin is shorted ?

Please check if any of the connector pin is shorted.

https://community.cypress.com/t5/PSoC-4-MCU/miniProg3/m-p/241439

Please refer to above thread.

As you have mentioned you have tried all the software solutions, problem may be due to hardware so can you please check that and let us know.

 

Thanks,

Krupashankar

0 Likes
CleoQc
New Contributor

We use the miniprog3 in production, in China.  The factory is reporting that their 3 stations, all of them using the miniprog3, have stopped working.
When I look in our debug files, I see

did not find any USB device "usb"


The timing makes me wonder if we have the same issue as the OP?

This is a project I inherited from a previous engineering team, and I am just discovering it.  The fact that it's all in China doesn't help.

But yeah, sounds like it's the same issue, at the same time.  It makes me wonder if it's some Windows update?

0 Likes
Krupashankar
Moderator
Moderator

Hi ,

1)  Suggestion @CleoQc  The MiniProg3 programmer is not recommended for production programming. We suggest customers who need production programming support to consult our 3rd party programming vendors on our General Programming page or through our distribution partners: https://www.cypress.com/go/distributors

2)  Apologies @DHolden  for too many actions, can you please try updating the driver https://community.cypress.com/t5/PSoC-6-MCU/Facing-connection-issue-with-the-CY8CKIT-002-PSoC-MiniPr... Please try this and let us know.

3) If MiniProg3 is detected by PSoC programmer once can you please share that screen shot for our analysis.

4) Can you please tell if any yellow light glows during disconnection, this indicates configuration issues if possible please share the picture with us.

Thanks,

Krupashankar

 

0 Likes
DHolden
New Contributor

I'm already tried uninstalling/reinstalling the software and drivers.  It will connect on the first attempt, but if it fails to program/detect the power is enabled, it tells you to disconnect and reconnect the programmer, and then it will be undetected by windows.

when it fails to connect to windows, the lights blink on the programmer, but will stay off.

0 Likes
DHolden
New Contributor

Just tried again, it failed during the programming, and now it is an unknown device in windows

0 Likes
Krupashankar
Moderator
Moderator

Hi @DHolden ,

Thanks for providing the screenshot!

Based on your screenshot it is clear that firmware of MiniProg3 is up to-date Version 2.05 

Please try clicking toggle Power manually  and let us know if that helps

Krupashankar_0-1631813443381.png

Can you please confirm if any of the pins are shorted?

Have you tried the same steps on Windows 7 OS, are you facing the same issue even after binding the driver manually? If Windows update in (Windows 10) is the problem then MiniProg3 should have worked on Windows 7 OS.

 

Thanks,

Krupashankar

0 Likes
Krupashankar
Moderator
Moderator

Hi @DHolden ,

Can you please share the schematics of the connector sections and pins associated.

From your attached screenshot we are able to see that voltage is not detected properly at the MiniProg3.

Krupashankar_0-1631950125591.png

Please ensure your hardware connections is same as below

Krupashankar_1-1631950224470.png

https://www.cypress.com/file/37266/download

 

Thanks,

Krupashankar

 

0 Likes