cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

Anonymous
Not applicable

hi to all,

   

         i have installed both psoc creator 1.0 and creator 2.0 in my pc which is working with windows 7. But, when i tried to program my code with creator 1.0, it is programming successfully...but the same when i trying with creator 2.o i couldnt program my code to first touch starter (CY8cKIT-003) kit....

   

basically, when i tried to make my LED connected to P2[0] of first touch kit to glow....i am unable to use creator 1, because of not having pins in its component list....but by using creator 2.0 i am able to write the program to glow led connected to p2[0] of first touch kit due to presence of pins in the component list of creator 2.0, but eventhough it builds successfully,  when i tried to program it, it is asking to select the target device...when i select the target device and click "ok" then it is showing "ready" message at the down left corner of window.....which is confusing whether it programmed or not....if i convinced myself it as programmed....my LED is not blinking as per my code.......any way iam not getting that "program successfuly completed" message.

0 Likes
1 Solution
JoMe_264151
Expert II

This is a bit complicated since Creator 1.0 is a very old version, 2.0 superseded by 2.1 already.

   

2.1 does not support the older ES2-silicons any more, but 2.0 still does.

   

Probably your 2.0 version is not quite correct installed. You can find a downloadable version here http://www.cypress.com/?rID=39551 

   

 

   

Bob

View solution in original post

0 Likes
6 Replies
JoMe_264151
Expert II

This is a bit complicated since Creator 1.0 is a very old version, 2.0 superseded by 2.1 already.

   

2.1 does not support the older ES2-silicons any more, but 2.0 still does.

   

Probably your 2.0 version is not quite correct installed. You can find a downloadable version here http://www.cypress.com/?rID=39551 

   

 

   

Bob

View solution in original post

0 Likes
JoMe_264151
Expert II

Oh, and I forgot: There is an exchange-program     http://www.cypress.com/?rID=53994 to get you the latest revision of your FirstTouch-board. This will help you to use the latest revision of the Creator-software (2.1)

   

 

   

Bob

0 Likes
Anonymous
Not applicable

hi Mr.Bob

   

Thanks for ur reply, did you mean that the psoc creator 2.0 is not compatible with the earlier version of First touch kit(CY8Ckit-003) ?

0 Likes
Anonymous
Not applicable

hi bob....

   

     Till now i am using the first touch kit belongs to my college.....now i would like to buy a kit of PSOC3 on my own....can you please suggest me the kit to which creator 2.0 and 2.1 are compatible in windows 7 platform.

0 Likes
ETRO_SSN583
Esteemed Contributor

Here are Creator Requirements -

   

 

   

http://www.cypress.com/?rID=39551

   

 

   

Note you should use, generally speaking, latest release, 2.1, as it contains

   

both improvements and bug fixes.

   

 

   

For kits read their updated release notes online, kits to focus

   

on CY8CKIT -030 or CY8CKIT-001.

   

 

   

Regards, Dana.

0 Likes
ETRO_SSN583
Esteemed Contributor

So there is no confusion here are 2.0 and 2.1 requirements for Creator -

   

 

   

Windows Operating System

   
        
  • Windows XP SP2 or SP3
  •     
  • Windows Vista (32- and 64-bit supported) and SP1
  •     
  • Windows 7 (32- and 64-bit supported) and SP1
  •     
  • MacOS v10 with Parallels Desktop v6 running Windows XP SP3
  •    
   
        
  • 1 GHz CPU
  •     
  • 512 MB RAM (minimum), 1 GB RAM (preferred)
  •     
  • 2 GB of hard disk space
  •     
  • USB 2.0
  •     
  • 1024x768 screen resolution 
  •    
   

 

   

Regards, Dana.

0 Likes