cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

Anonymous
Not applicable

Hello,

   

I am in the process of modifying an existing application.  The current modification is adding the default Cypress Audio device to an USBFS component.  That appears to have worked and the PC does recognize the audio device.  However the PC (Win 7 64 bit) can not find a device driver.  I performed due diligence and searched  forums and and also a general internet search and can not find information regarding this specific issue.  But if I missed it , I apologize in advance.

   

NOTE: 02/21/2016.  The project has been updated.  The new audio device is the same as the audio device from a sample Cypress project.  The Cypress supplied project works and functions correctly.  The audio device is recongnized by Windows and functions normal.  However when this same audio device is added to the project I am attempting to modify,  Windows fails and indicated it can not find a driver.  Apparently there is a conflict somewhere in the USBFS component and the two audio devices are causing an issue.

   

Attached are the Cypress supplied project,  the project I am attempting to modify and two screen shots related to the two projects.

   

 

   

Regard,

   

Ron

0 Likes
Reply
5 Replies
Employee

Hello Ron,

   

Can you please try adding Interface Association Derscriptor also.

   

Thanks,

   

Hima

0 Likes
Reply
Anonymous
Not applicable

Hello Hima,

   

I have implemented that and only made things worse.  Now the original audio devices will not start.  Again, Windows complains about no driver available.  The project is attached. 

0 Likes
Reply
Anonymous
Not applicable

Hima,

   

BTW this is being developed on a CY8CKIT-059 which should allow for easy replication.

   

Regards,

   

Ron

0 Likes
Reply
Anonymous
Not applicable

Hello,

   

I could really use some help with this.  I submitted case and still have not heard back from Cypress going on two weeks.

   

Regards,

   

Ron

0 Likes
Reply
Anonymous
Not applicable

Hello,

   

Just want to let everyone know that Cypress did get back to me regarding the issue.  Somehow the notification email was missed by me (and perhaps deleted) or it was not delivered.  Cypress support is excellent, and it was surprising when I did not hear back from them.

   

Regards,

   

Ron

0 Likes
Reply