cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

AzGa_264406
New Contributor
        As I know ICE-4000 is compatible with PD v.4.3 and not compatible with v.4.4 and later. So my question: what happen if I try to load hex-file which was worked out by PD v.5.3 into ICE-4000, using the PD v.4.3. Will it worked?   
0 Likes
3 Replies
Anonymous
Not applicable

Which device are you using? See following KB article on PSoC devices supported by ICE4000 -

   

http://www.cypress.com/?id=4&rID=45620

   

 

   

You may have to install PSoC programmer v2.33. See below KB article -

   

http://www.cypress.com/?id=4&rID=34495

   

It is not possible to program in PD4.2 with a hex file generated by some other project; in this case, PD5.3 project.  

0 Likes
AzGa_264406
New Contributor

 I'm using CY8C27443.

   

I studied the problem and believed that the structure of hex-file should not in principle depend on the version of the program in which the file was created. The structure should be unified, is not it?

0 Likes
Anonymous
Not applicable

I also think so. Hex file format should not change. But I am not 100% sure. 

   

However, the main issue here is not the designer version but the programmer software version.You should have v2.33 to talk to ICE4000. 

0 Likes