cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

Anonymous
Not applicable

Hi all,

   

I would like to ask for a bit of help to soft out my troubles with my ancient old arch enemy - the I2C bus 🙂

   

My setup is this: a 29566 device acting as a master, and using the P1[5] and P1[7] lines. I managed to successfully run a I2Cm module and verify the communication. However I need 400k speed and trying to use the I2CHW module instead. Just repeating the example code for a single master device and it always hangs on this line:
while(!(I2CHW_bReadMasterStatus()&I2CHW_WR_COMPLETE));

   

I also tried the option:
while(I2CHW_bReadI2CStatus()&I2CHW_ISR_ACTIVE);, again with no success.

   

Don't know what to try next...

0 Likes
3 Replies
ETRO_SSN583
Esteemed Contributor

Some thoughts -

   

 

   

1) Have you looked at SDA, SCL with a scope to verify signal integrity ?

   

2) Did the project run at 100 K speed ?

   

3) Post your project so forum can look at settings -

   

 

   

    

   

          

   

“File”                                                           Designer

   

“Archive Project”

   

 

   

Regards, Dana.

0 Likes
ETRO_SSN583
Esteemed Contributor

Some thoughts -

   

 

   

1) Have you looked at SDA, SCL with a scope to verify signal integrity ?

   

2) Did the project run at 100 K speed ?

   

3) Post your project so forum can look at settings -

   

 

   

    

   

          

   

“File”                                                           Designer

   

“Archive Project”

   

 

   

Regards, Dana.

0 Likes
Anonymous
Not applicable

 Yes, I have verified the connections. Actually I had it perfectly running with I2Cm software I2C module, but since it is only limited to 100k speed that's why I need the hardware one.

0 Likes