cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

Anonymous
Not applicable

I keep on getting this error.

   

I am using a custom board layout with a CY8C3244LTI-123 chip.  There was an error while execute any function (programm,checksum, read, verify, or erase.) :   (PSoC  Programmer received error (FAILED! Can not enter Debug Mode of PSoC3 device)).   

   

PSoC programmer version is 3.12.5.868

   

I made next the custom board layout with another CY8C3244LTI-123 chip and tried enter Debug Mode, but unsuccessfully. 
 When I tried programming  the device out of PSoC Creator, then  device  CY8C3244LTI-123 is visible, but no by connecting.  

   

 

   

When I received these chips, the package contains the inscription "p/n:CY8C3244LTI-123-ND". What it means "ND". 
 

0 Likes
Reply
5 Replies
Anonymous
Not applicable

Hi AlexeyM,

   

 

   

Are you powering the device externally or using Miniprog3 to power the device?

0 Likes
Reply
Anonymous
Not applicable

Could you tell us, what pins are being used for programming. PSoC3 on your custom board ?  

0 Likes
Reply
Anonymous
Not applicable

 Here pins that were used for programming:

   

SWDIO      P1[0]
SWDCLK  P1[1]
SWV          P1[3]
XRES        P1[2]

   

I using Miniprog3 to power the device.   Vddd=Vddio=Vdda=3.3volt

0 Likes
Reply
Anonymous
Not applicable

 I think I got the problem. I see that in your case you are not connecting the VTARG pin anywhere. You need to connect the VTARG pin of Miniprog3 to VDDIO1 of PSoC. Miniprog3 measures the voltage on VDDIO to see if the device is powered, since the SWD port pins lye in VDDIO1 quadrant of pins.

0 Likes
Reply
Anonymous
Not applicable

Also,ensure that you tie the grounds together!

0 Likes
Reply