cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

Anonymous
Not applicable

This is the

Environment:

PSoC Creator  4.1 Update 1 (4.1.0.3210)

Culture: English (United States)

OS Version: Microsoft Windows NT 10.0.16299.0

CLR Version: 4.0.30319.42000

The Error given in Creator is:

Programming started for device: 'PSoC 3 CY8C3866AX*-040'.

Device ID Check

Erasing...

Programming of Flash Starting...

Protecting...

Verify Checksum...

Finished Programming

Device 'PSoC 3 CY8C3866AX*-040' was successfully programmed at 04/24/2018 15:21:41.

Error: dbg.M0007: The run request failed.  Encountered error (Invalid thread id: 1)

Error: dbg.M0015: Debugger exited unexpectedly during run.  Encountered error (Remote communication error: No error.)

It has worked fine until this project. I started to use debug on March 23rd or 24th.

0 Likes
1 Solution
JoMe_264151
Expert II

Check in "System" view whether the debug option is not set to gpio.

Bob

View solution in original post

0 Likes
4 Replies
JoMe_264151
Expert II

Check in "System" view whether the debug option is not set to gpio.

Bob

View solution in original post

0 Likes
Anonymous
Not applicable

Hi Bob,

Found it. Fixed.

Many thanks to you and the community. I am new to using this community for answers.

Dale.

Sent from my iPad

0 Likes
pemac_1611436
New Contributor

Hello,

I have same problem, but in PSOC Creator 4.2 😞

I donot find debug option 😞

Can you help me, please.

0 Likes
JoMe_264151
Expert II

In Creator window "Workspace Explorer" (Left hand side) under Design wide Resources, double click on "System". There you'll find the debug option to change the pins to SWD instead of GPIO.

Bob

0 Likes