cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

New Contributor

I have a board I designed according to the CapSense design rules and I'm hoping somebody would be able to help me out with the issue I am having (I have attached a partial image of the board just to show its design for reference).

   

So, here is my issue. When I set my CapSense module to manual I get strong readings on all buttons and the slider, but seeing that we don't have time to do manual calibration for every single item these go in, this isn't very feasible especially with environmental factors having effect of the readings. When I set my CapSense to manual with run-time tuning the reading I get for my furthest button isn't as strong but is still plenty to set as a touch. Now the issue is that when I set my CapSense to SmartSense it barely gets a reading from this button at all. 

   

Is there anything I can do to make this reading stronger when using SmartSense? When I use manual or manual with run-time tuning I get a very strong reading so I doubt this is a board design issue and could probably be fixed somewhere in software, I just dont really know how. 

0 Likes
Reply
9 Replies
Honored Contributor II

Well I don't have your board or the complete circuit layers but from the design manual it appears that you may have some design issues with trace length and layout.  I am sending you the CapSense design guide.  The basic ideal is to make the board work and you won't need to do any tuning in production.

0 Likes
Reply
New Contributor

bobgoar: What might be the layout issue? I followed the design guide you attached when designing the board. The longest trace is actually only ~5" long and it calls for a max of 12".

0 Likes
Reply
Honored Contributor II

Here is a manual just for PSoC 4.

0 Likes
Reply
Honored Contributor II

You could open a case with Cypress and send your board files for a design review.

0 Likes
Reply
New Contributor

I might end up doing this today if I don't figure out the issue today.

0 Likes
Reply
Esteemed Contributor II

You are using an outdated CapSense component. I would suggest you to upgrade to Creator 4.0, update all your components and thest again.

   

 

   

Bob

0 Likes
Reply
New Contributor

I will be trying this out today and will let you know the out come.

0 Likes
Reply
New Contributor

I updated everything and tried it out on Creator 4 and it still had the same issue. I then enables the shield signal and it fixed the issue with that button but now one of my slider segments is receiving a much weaker signal on the borderline of a finger touch. When I switch it to manual they all still receive strong signals just when I put it on SmartSense it recieves it weaker.

0 Likes
Reply
Moderator
Moderator

Hi,

   

 

   

What sensitivity have you set in the configuration? You may try increasing sensitivity (decreasing the value) and check if it helps to provide sufficient signal.

   

 

   

Thanks,

   

Yuva.

0 Likes
Reply