cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

New Contributor II

have a CY8CKIT-059. I am unable to get the USBUART working. The device registers and works fine via programming port but not regular usb port. I have tried USBFS_UART example code and also other examples (for example the one on youtube). These projects build, compile and program the device fine. But once plugged in windows 10 does not show a new COM port or device. Nothing shows up in device manager and there is no sign of windows recognizing the device when plugged in via non-programming usb port. I have tried all the suggestions in the thread on CY8CKIT-50 however windows 10 still does not seem to register the device.  Is there something specific with this kit that I am missing?

0 Likes
Reply
1 Solution
Esteemed Contributor

Hi,

Just one more thing to ask you to confirm.

To use the regular USB connector of CY8CKIT-059

we use USB-A to USB-Micro-B cable.

And I have seen many USB-A to USB-Micro-B "charge only" cables for smart-phone/iPhone.

These cables have connections of only power and have no data lines.

Please take a look at the USB-A connector of your cable and if it has "USB" mark or "Power" mark.

Anyway, trying another USB Cable (A to micro-B) won't harm.

moto

P.S. Just like Noriaki Tanaka-san, your project worked fine on my CY8CKIT-059.

View solution in original post

8 Replies
Employee

Please confirm if the device is recognized by the Device Manager.  Are there any Unknown device in the device list?

If the device is not recognized as an COM device, you need to install the USB serial driver.  Please refer following document.

USB serial driver (Usbser.sys) - Windows drivers | Microsoft Docs

If any device is listed in the device manager, please confirm what happens with debugger to confirm where is the CPU running.

Regards,

Noriaki

0 Likes
Reply
Honored Contributor II

Please post your code so we can check it,

0 Likes
Reply
Employee

I didn't do anything special.  I just create a project from the code example USB_UART

Regards,

Noriaki

0 Likes
Reply
New Contributor II

Noriaki

Thanks for the code but it did not work on my machine. Did you use it in wondows 10 and with kit-059 (device: cy8c5888LTI-LP097)? I am able to program the device (i know this because I am able to blink leds along with starting usbfs-uart). When I unplug the programming port (disconnect kitprog) and connect the other end of kit-059, regular usb, windows does not see the device. There are no unknow devices in the device manager (also windows does not make any sound when the device is plugged in).

The serial driver link you posted suggests that no additional drivers are necessary on windows 10 if the usb device is programmed right.

I will attach my code.

0 Likes
Reply
New Contributor II

I have attached my code in a reply to Noriaki. Can you please check and let me know what I am doing wrong. Thanks

0 Likes
Reply
Employee

I have confirmed that your project is recognized as a USB serial device (COM23) connected to a Generic USB Hub on my Windows 10 64-bit operating system..

GS004348.png

Please reconfirm if your device is not recognized by Windows 10.  At first configure the device tree as a connection tree in the Device Manager.  Following menu item can be used.

GS004349A.png

Sorry, this is a Japanese version of operating system view.

Find a USB hub (or Root hub) you are going to use and confirm what is connected to the hub.

If you find any "Unknown device" at the tree, there is a problem in the device driver.

If you don't find any device, there is a problem in the Prototyping kit hardware.

Regards,

Noriaki

Esteemed Contributor

Hi,

Just one more thing to ask you to confirm.

To use the regular USB connector of CY8CKIT-059

we use USB-A to USB-Micro-B cable.

And I have seen many USB-A to USB-Micro-B "charge only" cables for smart-phone/iPhone.

These cables have connections of only power and have no data lines.

Please take a look at the USB-A connector of your cable and if it has "USB" mark or "Power" mark.

Anyway, trying another USB Cable (A to micro-B) won't harm.

moto

P.S. Just like Noriaki Tanaka-san, your project worked fine on my CY8CKIT-059.

View solution in original post

New Contributor II

Yup, cable was the problem. I changed the cable and everything started to work. I didn't have to install any new drivers.

Thank you very much!!