cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

Anonymous
Not applicable

Hello,

   

I have been working on CY8CKIT-050_PSoC 5LP DVK Kit it has CY8C5868AXI-LP035 on it. I have been programming it using PSOC creator 3.3 using on board USB programming. today it has stopped detecting the device and when I press port acquire button in select debug target it gives an error: There was an error running port acquire: Can not acquire SWD device! 

   

now its neither programming nor debugging.

   

What should I do to fix it. I have tried reinstalling the software and changing the cable but none of them works. Kindly help me ASAP.

   

 

   

Regards

0 Likes
Reply
3 Replies
Esteemed Contributor II

I suggest you to create a support case (at top of this page "Design Support"). You already have done all I would suggest to do.

   

 

   

Bob

0 Likes
Reply
New Contributor II

Hi All,

I am having this issue too, what is required from the PSOC chip during programming? do I need anything else more than power supply to the chip's pins?

Thanks,

Roy Roif.

0 Likes
Reply
Contributor II

If you have updated the PSOC Programmer to the latest, uninstall it along with the drivers, then install the previous version which is available from the Cypress website.

The inability to recognize the PSOC attached using KitProg in Windows is a listed issue with the programmer software update.

In my case I had installed the latest programmer software, and had the exact same issue.  By returning to the previous version of the PSoC Programmer, everything was fixed.

0 Likes
Reply