cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

rasec_2385561
New Contributor II

The USB Control Center seems to be different from the AN56377 testing example on page 56.

0 Likes
Reply
1 Solution
SrinathS_16
Moderator
Moderator

Hello,

- The USB Control Center has been modified slightly with the later versions of SDK releases. The latest one is available from the FX3 SDK package.

http://www.cypress.com/documentation/software-and-drivers/ez-usb-fx3-software-development-kit

- Error Code 997 indicates that the data is not sent to/received from the device and the request has timed out.

- Please let me know your scenario in which you face the issue.

Best regards,
Srinath S

View solution in original post

0 Likes
Reply
9 Replies
rasec_2385561
New Contributor II

What does the error code 997 mean in the USB Control Center ?

0 Likes
Reply
SrinathS_16
Moderator
Moderator

Hello,

- The USB Control Center has been modified slightly with the later versions of SDK releases. The latest one is available from the FX3 SDK package.

http://www.cypress.com/documentation/software-and-drivers/ez-usb-fx3-software-development-kit

- Error Code 997 indicates that the data is not sent to/received from the device and the request has timed out.

- Please let me know your scenario in which you face the issue.

Best regards,
Srinath S

View solution in original post

0 Likes
Reply
rasec_2385561
New Contributor II

I figured out the inconsistency between the USB Control Center and the documentation, AN56366. I was sending data and receiving data back. And the documentation asks you to send a zero length data transfer for control purposes. I figured out I was clicking on the wrong point on the expanded tree. Maybe that should be considered for a documentation update. Its real easy to miss the important information there.

As for the error code 997, I was just trying to do a bulk transfer in and out. Here is the log.

BULK OUT transfer

0000 01 11 11 11 11 11 11 00

BULK OUT transfer completed

BULK IN transfer

0000 00 41 00 37 00 44 00 35 00 41 00 35 00 44 00 30

0010 00 30 00 38 00 39 00 00 00 00 00 00 00 00 00 00

0020 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

0030 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

BULK IN transfer completed

BULK IN transfer

BULK IN transfer failed with Error Code:997

BULK OUT transfer

0000 11 11 11 11 11 11 11 11

BULK OUT transfer completed

BULK IN transfer

BULK IN transfer failed with Error Code:997

BULK OUT transfer

BULK OUT transfer failed with Error Code:997

error1.png

Please note that there are two KitProg items on the left expanded tree. And they have different VID/PID values. The first item is correct and the second is something the system came up with on its own. Which is probably what my problem is here. I have been sending to the second item which is made up by the system. It is a hold over from when I changed the PID and should no longer exist but for some reason it is still hanging around. In the past I have uninstalled it. Windows device manager says that both versions are using the PSoCUSB3.sys device driver. Which is not what I installed. I installed the KitProg.sys device driver 1.2.3.3. Any ideas ?

0 Likes
Reply
Sananya_14
Moderator
Moderator

Hello,

It appears like you are unable to view your programmed device on Control Center and hence the data transfer is not proper. Please make sure that the VID/PID in your USBFS component is programmed properly and the device binds properly to the cyusb.sys driver. Once that is done properly, it should come up in the Control Center and you can select the appropriate endpoints and carry out your data transfer.

Best Regards,

Sananya

0 Likes
Reply
rasec_2385561
New Contributor II

Ok, I removed the old VID/PID entry in Microsoft Device Manager and then rebooted my PC. The VID/PID settings remained as expected. Retesting the AN56377 project 2 went well. The only issued that I noticed was in PSocCreater 4.1 . The destination board doesn't appear if you want to program the board. The window of boards connected to the PC is just empty. I suppose changing the VID/PID might have some effect. What do you think ?

PS: In the output window after you rebuild, the output did say something about the code using a certain percentage of the onchip flash. So I am "assuming" the onchip flash got updated.

0 Likes
Reply
rasec_2385561
New Contributor II

Ok, I figured out why I could not select the device and program it. The device driver was missing for the KitProg programmer. Once installed correctly, it work fine.

So I have moved on the project 3 - Increasing USB Throughput with DMA. It built it ok and I programmed the device. Upon starting the Streamer application these doesn't seem to be anything in the Endpoint drop down field. Its empty. Any ideas why there is nothing in this field ?

0 Likes
Reply
rasec_2385561
New Contributor II

The Streamer is still an issue.

Randy

0 Likes
Reply
Sananya_14
Moderator
Moderator

Hello Randy,

Please configure the endpoints properly along with the VID/PID in the USBFS component as per Section 16.1 in the App Note. After programming the device, it will bind to the cyusb.sys driver and you should be able to see the proper endpoints in Streamer as well.

Best Regards,

Sananya

0 Likes
Reply
rasec_2385561
New Contributor II

After reconfiguring the VID/PID the Streamer application works temporarily. After exiting the application and restarting it, the endpoints do not show up and at times the device driver fails to load or unloads.

In the USB Control Center the behavior is much the same. the USB control center application works temporarily. After exiting the application and restarting it, the ISOC item in the left hand pane do not show up. I am still working on the AN56377 project 3.

0 Likes
Reply