cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1 MCU

Anonymous
Not applicable

This is a continuation of this thread: http://www.cypros.org/?app=forum&id=0&rID=89110  I was able to find an alternative means to work around the problem, but I have again run into this issue.  I've tried all the suggestions in the thread, and nothing has worked.  There seems to be confusion that I am getting faulty values... that isn't the issue.  The issue is when using the ADC to read values after calling ADC_SelectConfiguration(), no values are returned *at all*.  It actually gets caught up in the ADC_IsEndConversion(uint8 retMode) function in the ADC.c file.  The ADC_DEC_SR_REG register never gets set to 1, and so, the function blocks until I quit the program.  It works fine if I never call SelectConfiguration.

   

Can anyone help me figure out what's going on?  I haven't been able to find this issue anywhere else on the forum.  

0 Likes
3 Replies
ETRO_SSN583
Esteemed Contributor

You might consider filing a CASE on this, and post your project when

   

you file the case -

   

 

   

    

   

          

   

To create a technical case at Cypress -

   

 

   

www.cypress.com

   

“Support”

   

“Technical Support”

   

“Create a Case”

   

 

   

You have to be registered on Cypress web site first.

   

 

   

Regards, Dana.

0 Likes
HeLi_263931
Honored Contributor II

Did you start / execute a conversion after selecting a new configuration?

Daniel_Pilon
New Contributor II

Many delta sigma functions are interrupt based and can create problem with other interrupt (ex.: use theses functions inside an interrupt). Is it your case?

0 Likes