cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

D_Sd_3235936
New Contributor II

Receiving a CYBLE 224116 (4.2) to upgrade from 224110 (4.1)

Do I need to make any specific changes in the Top Design/Code?

0 Likes
1 Solution
VenkataD_41
Moderator
Moderator

Hi,

The best practice for upgrading the project from one module to new module is as follows:

1. Open the old project (project with 224110) in your case in new version of PSoC Creator (4.2 in your case) and upgrade all the components and build it. Ensure that build is sucess.

Find the path Project --> Update components to update the components.

2. Create an empty project (in creator 4.2)  for the new module that you are going to port to. It is CYBLE 224116 in your case.

3. Copy all the contents from old project's schematic to the new project. Copy all the necessary files and replace main.c . Build it. If any build errors come that may be because the limitation of the features in new module (i.e. CYBLE 224116) in your case.

Another advice is please use latest version of PSoC Creator i.e. PSoC Creator 4.4 for your development.

Hope this helps. Please update if you have any queries.

Thanks

Ganesh

View solution in original post

0 Likes
1 Reply
VenkataD_41
Moderator
Moderator

Hi,

The best practice for upgrading the project from one module to new module is as follows:

1. Open the old project (project with 224110) in your case in new version of PSoC Creator (4.2 in your case) and upgrade all the components and build it. Ensure that build is sucess.

Find the path Project --> Update components to update the components.

2. Create an empty project (in creator 4.2)  for the new module that you are going to port to. It is CYBLE 224116 in your case.

3. Copy all the contents from old project's schematic to the new project. Copy all the necessary files and replace main.c . Build it. If any build errors come that may be because the limitation of the features in new module (i.e. CYBLE 224116) in your case.

Another advice is please use latest version of PSoC Creator i.e. PSoC Creator 4.4 for your development.

Hope this helps. Please update if you have any queries.

Thanks

Ganesh

View solution in original post

0 Likes