cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

vegan_electron
New Contributor II

Dear forum members,

we would like to update the firmware trough OTA. We actually do this but now it's required to handle an encrypted firmware.

As far i have seen PSOC4 is not supporting this. Means we have to switch the platform maybe to psoc5 or so? Or is there

a better solution which doesn't end up in so many changes in the electric schematics? Read there is required an external

memory.

Thank you for any advice. Kind regards,

Daniel

0 Likes
Reply
1 Solution
GeonaP_26
Moderator
Moderator

CE222802 - PSoC 6 MCU Encrypted Bootloader supports encrypted firmware bootloading or with encrypted signature. PSoC 4 do not have any CRYPTO block. Instead you can use custom/external libraries.

View solution in original post

0 Likes
Reply
1 Reply
GeonaP_26
Moderator
Moderator

CE222802 - PSoC 6 MCU Encrypted Bootloader supports encrypted firmware bootloading or with encrypted signature. PSoC 4 do not have any CRYPTO block. Instead you can use custom/external libraries.

View solution in original post

0 Likes
Reply