cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

Steffen
New Contributor

I've been learning how to use PSoC by the tutorial vids. In lesson 4 I encountered a problem, when it came to the hardware connection between the switch and the LED.

The error is: "Pin guidance unavailable. Pin cannot be placed at X. Pin cannot be used for routed connections." for both the input and the output pin as soon as i connect them by wire in my TopDesign.

The goal would be to directly turn on the LED by pressing the switch as described in the tutorial.

Is this a configuration problem or is my board not able to do hardware connections (which I doubt).

 

I'm using PSoC Creator 4.4 and the CY8CKIT-149 PSoC 4100S Plus Prototyping Kit, CY8C4147AZI-S47564.

 

I attached the project.

I'd be very grateful for an explanation of this error and even more for a solution.

0 Likes
3 Replies
BiBi_1928986
Valued Contributor

Hello Steffen.

I have no experience with 4100S Plus device.  However, I do know it uses Smart I/O inter-connections and this is very different from the DSI inter-connections of other PSoC's (such as CY8C4245).  I would suggest you review the technical documentation of 4100S Plus to learn about Smart I/O.  The datasheet can only take you a little distance.  You might also look at the code examples included with Creator installation.  Maybe something useful will be found there.

PSoC 4100S and PSoC 4100S Plus: PSoC 4 Architecture Technical Reference Manual (TRM) (cypress.com)

PSoC(R) 4100S Plus PSoC 4 Registers Technical Reference Manual (TRM) (cypress.com)

Also, I saw your other question about using the clock component.  I suspect this is a similar issue with Smart I/O vs DSI.  Maybe someone from Cypress will respond with a better answer for you.

And search for Smart I/O on Cypress site.  There are many good examples.
Cypress Search

Good luck with your project.

0 Likes
AlanH_86
Employee

The "S" chips do not have a DSI... so you can't do that wire.

You need a PSoC4A (like on the CY8CKIT-042)

Alan

0 Likes
Aashita_Raj
Moderator
Moderator

Hi @Steffen ,

Can you please have a look at one of the thread here for quicker help : Solved: PSoC with 4100PS error with hardware connection - Cypress Developer Community  ? Please go through this. It will help you debug the issue on your end.

Best Regards,

Aashita

0 Likes