cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

JuPa_302041
New Contributor II

Hi All,

   

I managed to configure all the settings for a 4x20 character LCD I just cant figure out why some words or numbers are not completely written to the LCD, 

   

for instance in the example the string text was "Cypress", I got Cyrss, if I send number 2015 I got 205, I cant figure out what is going on

   

Please help me out

   

I appreciate your help

0 Likes
Reply
1 Solution
JoMe_264151
Expert II

You did not tell which board you use: Own pcb? Cypress kit?? Which one ???

   

Depending on the board there are already I2C pullups mounted.

   

Your device is set (in system resources) to 5V, your LCD is powered with 3.3V, does that match? How is your PSoC powered?

   

You may reduce (as a test) the I2C speed to 50kHz.

   

 

   

Bob

View solution in original post

0 Likes
Reply
3 Replies
JoMe_264151
Expert II

You did not tell which board you use: Own pcb? Cypress kit?? Which one ???

   

Depending on the board there are already I2C pullups mounted.

   

Your device is set (in system resources) to 5V, your LCD is powered with 3.3V, does that match? How is your PSoC powered?

   

You may reduce (as a test) the I2C speed to 50kHz.

   

 

   

Bob

View solution in original post

0 Likes
Reply
rola_264706
Honored Contributor II

Juanes: Spec for the NewHaven display says 5.0 volts and your design says 3.3v I would fix that issue.  Also the Spec says that it takes 1ms for writes so you may need to change your delays. If you are using a pioneer board it already has pullup resistors. So with yours you are reducing the pullup value due to the resistors in  parallel .

0 Likes
Reply
JuPa_302041
New Contributor II

Thank You Bob and Bob Goar, Im new to I2C thanks for your help!!

0 Likes
Reply