cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

ZiGa_4301356
New Contributor

I'm trying to be build SimpleLedCapsense bleapp for IOS from GitHub - cypresssemiconductorco/bleapp  for my lab project. It gave back a lot error. I was trying to fix the error but it's not work well. Any help will be appreciated!

0 Likes
1 Solution
DheerajK_81
Moderator
Moderator

The latest version of Cysmart source code has been developed using XCode 10.1. Please download the source code from here: https://www.cypress.com/documentation/software-and-drivers/cysmart-mobile-app

I think you might have downloaded an older source code which targets Swift 2.x and hence the error.

Regards,

Dheeraj

View solution in original post

3 Replies
DheerajK_81
Moderator
Moderator

Which version of XCode are you using? Please attach the log of the errors you are seeing so that we can get more insight on the issue.

Regards,

Dheeraj

0 Likes
ZiGa_4301356
New Contributor

I used the latest version at the beginning and it does not support Swift Complier- language : "Swift 3". So then, I tried with Xcode 10.1, Which supports Swift 3. But it says it can not support building or migrating Swift 2.x targets. It wants me to use Xcode 8.x. Now the problem is Xcode 8.x is not compatible with macOS Catalina. What should I do?

Screen Shot 2019-11-21 at 10.48.20 AM.png

Sincerely,

Condor,

Ziyang Gao

0 Likes
DheerajK_81
Moderator
Moderator

The latest version of Cysmart source code has been developed using XCode 10.1. Please download the source code from here: https://www.cypress.com/documentation/software-and-drivers/cysmart-mobile-app

I think you might have downloaded an older source code which targets Swift 2.x and hence the error.

Regards,

Dheeraj

View solution in original post