cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

1 Solution
Employee

Boris,

Have you tried to install additional devices using the menu "Tools->Find new devices"?

GS004583.png

I am not installing additional devices due to some reasons.

Or "Tools->Find new components" may be effective to revise some components with new one.

Regards,

Noriaki

View solution in original post

7 Replies
Employee

Because CY8C4246AZI-M443 has three SCBs and SCB[3] cannot be assigned.  Please refer the ordering information table on the "PSoC® 4: PSoC 4200M Datasheet"

GS004580.png

It was found that all 48-TQFP packages have three SCBs.  Please use 64-TQFP or 68-QFN.

Regards,

Noriaki

New Contributor

Hello,

Yes I know it has only 3 SCB, but only 2 are reachable.

SCB0 on port 1 or 4

SCB1 on port 0 or 2 or 3

SCB2: on port 5: not available on this model

SCB3: on port 6 or 7

2019-11-05_140522.jpg

How can I use the 3 SCB on this model?

Kind Regards,

Boris

0 Likes
Reply
Employee

Boris,

I tried putting three EZI2C components only.

GS004581.png

When built, PSoC Creator says there is no solution.

GS004582.png

So, I recognized that this MPN cannot have three SCBs regardless of the datasheet description.

I don't know why SCB[3] is disabled instead of SCB[2] on this MPN.

Does anyone have an idea?

Regards,

Noriaki

0 Likes
Reply
New Contributor

Hello Noriaki,

One of my collegue tryed it on his computer, and he succeded to use 3 SCB on the same PSoC.

The question is: why does it not work on my computer?

I have installed the last software (psoc Creator) downloaded on Cypress web site.

I didn't found where the MPN definition files are stored. Perhapst it is linked to such files.

2019-11-06.jpg

0 Likes
Reply
Employee

Boris,

Have you tried to install additional devices using the menu "Tools->Find new devices"?

GS004583.png

I am not installing additional devices due to some reasons.

Or "Tools->Find new components" may be effective to revise some components with new one.

Regards,

Noriaki

View solution in original post

New Contributor

Hello Noriaki,

I tryed it. It seems not to have worked. I tryed the solution of Bibi. It worked.

I tryied to open my original project: now it works.

I think it was necessary to close the project and reopen after "find new device" operation.

Thank all lot (at all) for your help.

Kinds Regards,

Boris.

0 Likes
Reply
Contributor II

Hello Boris.

To narrow down where the issue is, have your colleague archive the project and pass it to you.  Then, open it on your computer.

Archiving a PSoC Creator Design

You can try all 3 different archive types (Minimal, Complete, Bundle) to see which one breaks down on your computer.

Hope this helps.

Bill