cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

Anonymous
Not applicable

Hello,

   

I just bought the PSoC4-BLE kit and I was trying the sample codes which are given on cypress website.

   

However, the kit I received is older version and it has CySmart USB Dongle CY5670. And when i tried to open the cysmart software in windows 10, it asks me to upgrade firmware of dongle to 1.0.0.50 or above.

   

Please assist me how can I upgrade the firmware of dongle in order to use it with CySmart software.

   

Thanks!

0 Likes
1 Solution
rola_264706
Honored Contributor II

Here are the hex files in a Zip folders

View solution in original post

0 Likes
3 Replies
rola_264706
Honored Contributor II

Use PSOC programmer to program the dongle.

   

Refer section 3.6 in CY8CKIT-042 BLE kit Guide for details.

0 Likes
rola_264706
Honored Contributor II

Here are the hex files in a Zip folders

View solution in original post

0 Likes
Anonymous
Not applicable

Thanks bobgoar.

   

Easy Solution I found is as follows.

   

Open Psoc Programmer software > utilities > update

   

It would download and install new firmwares automatilcally.