cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

user_2312961
New Contributor

Hi all. I'm new on cypress PSOC. I'm from PIC24 and PIC32 and i no understand the logic of cypress documents and components.

   

I'm bought a kit for PSOC 4 BLE, and later, i saw those dongles: CY5677 and CY5670. The schematics and PSOCs on those dongles are the same, but one say BLE 4.2 and the other BLE 4.1. Can i actualice the CY5670 to 4.2 BLE?

   

 

   

Thanks

0 Likes
1 Solution
AnjanaM_61
Moderator
Moderator

Hi,

   

CY5670 and CY5677 uses different chip. CY5670 is compatible only for BLE 4.1 spec - which means it will support BLE 4.1 features but not BLE 4.2 features. CY5677 is compatible for 4.2 - which means both BLE 4.1 , 4.2 features are supported by CY5677.

   

Thanks & Regrds,

   

Anjana

View solution in original post

0 Likes
5 Replies
AnjanaM_61
Moderator
Moderator

Hi,

   

CY5670 and CY5677 uses different chip. CY5670 is compatible only for BLE 4.1 spec - which means it will support BLE 4.1 features but not BLE 4.2 features. CY5677 is compatible for 4.2 - which means both BLE 4.1 , 4.2 features are supported by CY5677.

   

Thanks & Regrds,

   

Anjana

View solution in original post

0 Likes
madac_652656
New Contributor

How can you tell which version of the dongle you have?  Mine (just purchased) only says BLE Dongle on the end and there are no chip numbers on the silkscreen.

0 Likes
himam_31
Employee

Can you check the cover. It will be mentioned there. Or check the part number of PRoC chip.

   

 

   

Thanks,

   

Hima

0 Likes
madac_652656
New Contributor

Thanks.  The cover sheet (from a CYC8CKIT-042-BLE) says CY5671 using a CYBL10162.  So I guess this means the 4.2 features mentioned above are not there?

0 Likes
himam_31
Employee

Yes. That's correct.

   

Thanks,

   

Hima