cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

Anonymous
Not applicable

The original project used BLE v1.20 and included one byte of dynamic Manufacturer Specific Data in the Advertisement packet.  Upgrading the component to v2.10 causes the Manufacturer Specific Data to be dropped.  The count byte just before the 2-byte company ID is unchanged.  I would go back to v1.20 but need to stay in Fast Advertising Mode.

0 Likes
Reply
1 Solution
Anonymous
Not applicable

A followup with the resolution from Cypress:

   

"
In the project replace the line 221

   

if(CyBle_GetBleSsState() == CYBLE_BLESS_STATE_ACTIVE)

   

in DynamicADVPayloadUpdate() function, main.c with the line

   

if(CyBle_GetBleSsState() == CYBLE_BLESS_STATE_EVENT_CLOSE)

   

It will update the advertising packets /scan response in BLE v2.1

   

The internal code of API

   

CyBle_GapUpdateAdvData() is changed in BLE 2.1 so that's why it is not working with the same project.

   

"

View solution in original post

0 Likes
Reply
3 Replies
Anonymous
Not applicable

A little more investigating shows the data is being transmitted but not being updated.  The code

   

  advPayload[MANUFACTURER_SPECIFIC_DYNAMIC_DATA_INDEX] = dynamicPayload++;

   

on line 232 of main.c is not updating the discovery data.

0 Likes
Reply
Anonymous
Not applicable

Please raise a technical support case at www.cypress.com -> click on 'Design Support' -> Under Support, click on 'Create a Support Case'.

   

You need to be registered first for raising a technical support case.

0 Likes
Reply
Anonymous
Not applicable

A followup with the resolution from Cypress:

   

"
In the project replace the line 221

   

if(CyBle_GetBleSsState() == CYBLE_BLESS_STATE_ACTIVE)

   

in DynamicADVPayloadUpdate() function, main.c with the line

   

if(CyBle_GetBleSsState() == CYBLE_BLESS_STATE_EVENT_CLOSE)

   

It will update the advertising packets /scan response in BLE v2.1

   

The internal code of API

   

CyBle_GapUpdateAdvData() is changed in BLE 2.1 so that's why it is not working with the same project.

   

"

View solution in original post

0 Likes
Reply