cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

masac_1860766
New Contributor

Hi,

I was using cysmart 1.2 c# api with cypress ble dongle 5677 , now we got new red color 4.2 cypress dongle which is not working in cysmart 1.2 but working fine with cysmart 1.3 application. but C# api  is not working with 1.3 reference dlls. It is showing error as attached.

0 Likes
1 Solution
DheerajK_81
Moderator
Moderator

Please go to Properties > Build, change the Platform target to one of them (either x86 or x64) depending on which architecture your running on and not "Any CPU" as shown in the picture attached. You need to choose a specific target because the DLL references are platform specific. When you debug/run the application now, you no longer will be seeing the warning.

This warning is common to both 1.2 and 1.3 DLLs if you don't specify the architecture.

Regards,

Dheeraj

View solution in original post

0 Likes
1 Reply
DheerajK_81
Moderator
Moderator

Please go to Properties > Build, change the Platform target to one of them (either x86 or x64) depending on which architecture your running on and not "Any CPU" as shown in the picture attached. You need to choose a specific target because the DLL references are platform specific. When you debug/run the application now, you no longer will be seeing the warning.

This warning is common to both 1.2 and 1.3 DLLs if you don't specify the architecture.

Regards,

Dheeraj

View solution in original post

0 Likes