cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

Anonymous
Not applicable

I'm running an application with Cyble-014008-device. All works fine, but when I try to enable the resolving list it does not work.

The APIs for that are available in PSoc-Creator 4.0.

I think the issue is, that the device is a BLE4.1 device. Is it possible to upgrade the stack-firmware to BLE 4.2 or is it neccessary to change

my device to 214015 ?

0 Likes
Reply
1 Solution
Employee

Hello,

      As e.pratt_1639216  mentioned, upgrading the BLE Stack only will not enable the BLE 4.2 features . The hardware should also support for it.

Anyways, coming to your resolving List Query --- The difference between the BLE 4.1 and 4.2 device  regarding the resolving list is -in BLE 4.1 ,the resolving list is a part of BLE Host  (Software) and in BLE 4.2 ,it is a part of the BLE Controller (hardware).

You can use the feature of resolving list with BLE 4.1 device as well. Please refer the code example from here on use of Resolving List with BLE 4.1 device.

PSoC-4-BLE/100_Projects_in_100_Days/Day027_BLE_Power_Measurement at master · cypresssemiconductorco/...

Regards,

Gyan

View solution in original post

2 Replies
Anonymous
Not applicable

I believe you can upgrade the Firmware stack by right-clicking your PSoC project and selecting "Update Components", but it will not be able to implement any features that require update hardware without updating the board to a newer version that supports BLE v4.2 features.

Based on what you mention for the resolving list being what you want changed, since that is a software change (I think?), then I would suspect it to work with just a BLE stack firmware upgrade by programming the chip with updated components. (If you implemented the OTA with BLE stack upgradeable, then you can also use that method as well).

If updating the components and working with the resolving list using that change doesn't work, just post on here again and let us know

Useful information on BLE v4.2: http://www.electronicdesign.com/communications/ble-v42-creating-faster-more-secure-power-efficient-d...

0 Likes
Reply
Employee

Hello,

      As e.pratt_1639216  mentioned, upgrading the BLE Stack only will not enable the BLE 4.2 features . The hardware should also support for it.

Anyways, coming to your resolving List Query --- The difference between the BLE 4.1 and 4.2 device  regarding the resolving list is -in BLE 4.1 ,the resolving list is a part of BLE Host  (Software) and in BLE 4.2 ,it is a part of the BLE Controller (hardware).

You can use the feature of resolving list with BLE 4.1 device as well. Please refer the code example from here on use of Resolving List with BLE 4.1 device.

PSoC-4-BLE/100_Projects_in_100_Days/Day027_BLE_Power_Measurement at master · cypresssemiconductorco/...

Regards,

Gyan

View solution in original post