Announcements
Community Announcement : Welcome to the NEW Cypress Developer Community.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

saga_1136906
New Contributor

Hi,

I'm using AN86233_DeepSleepADC.cydsn project, but the current is about 1.8mA insted of 9uA as read in comments of project. Someone can explain me the reason?

Tanks in advance! 

0 Likes
1 Solution
Rakshith
Moderator
Moderator

Hi @saga_1136906

Additionally, can you create a new project which just sends the device to deep sleep and let us know your measurements in this case? 

Were you able to measure the current with just the deep sleep API in an empty project? This would provide a rough idea about the current consumption when no components are enabled. A high current in this stage would point towards leakage current in the board. Also, please ensure that the debug select in the Systems tab in the DWR file is set to GPIO.

Thanks and Regards,
Rakshith M B

View solution in original post

0 Likes
4 Replies
Rakshith
Moderator
Moderator

Hi @saga_1136906

Can you please provide further information regarding your setup? Which target device are you using and how are you measuring the current?

Additionally, can you create a new project which just sends the device to deep sleep and let us know your measurements in this case? 

Thanks and Regards,
Rakshith M B
0 Likes
saga_1136906
New Contributor

Hi, 

I use CY8CKIT-042-BLE Pioneer baseboard. With CY8C4247LQI-BL483.

The project is pratically unaltered

Thanks

 

0 Likes
Rakshith
Moderator
Moderator

Hi @saga_1136906

Additionally, can you create a new project which just sends the device to deep sleep and let us know your measurements in this case? 

Were you able to measure the current with just the deep sleep API in an empty project? This would provide a rough idea about the current consumption when no components are enabled. A high current in this stage would point towards leakage current in the board. Also, please ensure that the debug select in the Systems tab in the DWR file is set to GPIO.

Thanks and Regards,
Rakshith M B

View solution in original post

0 Likes
saga_1136906
New Contributor

Hi,

Solved.

Thanks!

0 Likes