cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

Anonymous
Not applicable

HI ,

I'm using CYBLE-202007-1 with OTA Bootloading for Stack and Application.

PSoC Creator  4.2 (4.2.0.641). GCC 5.4-2016-q2-update.

The Example Solution "BLE Upgradable Stack Example Projects 1.20"  with BLE component BL_v3_30 for Stack- and Application project works fine.

Using the latest BLE component BL_v3_53 in my projects delivers the following error, when compiling/linking the Application project.

Error: prj.M0266:

      Shared code exported by instance CyBle of component BLE_v3_53 is not identical to code expected by instance CyBle of component BLE_v3_53.

     (App=psoc_creator)

I cleaned and re-built all projects.

BLE Component names in Stack and Application project are the same.

Are there any other known issues?

I'd urgently need a solution for this issue.

Many thanks for your support in advance.

Cheers

Ernst

P.S. Attached my Workspace Archive

0 Likes
1 Solution
GyanC_36
Employee

Hello Ernst,

    Your project build successfully for me without any issues.

I just deleted all the previous generated source files and cleaned and rebuild all the projects by adding the correct dependencies.

While adding dependencies files please note that you are adding the files with correct configuration ( Debug or Release).

I attached your successfully build project here.

-Gyan

View solution in original post

0 Likes
2 Replies
GyanC_36
Employee

Hello Ernst,

    Your project build successfully for me without any issues.

I just deleted all the previous generated source files and cleaned and rebuild all the projects by adding the correct dependencies.

While adding dependencies files please note that you are adding the files with correct configuration ( Debug or Release).

I attached your successfully build project here.

-Gyan

View solution in original post

0 Likes