cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

Employee

Hi,

   

I use the CY8C4245AXI-483(CY8CKIT-042 Board) design the CapSense design. Then using the MiniProg3 as bridge tool to debug it in CapSense Tuner GUI.
using the MiniProg3 supply power to kit board.

   

The debug steps as below:
1. Using 5 pins to connect with CY8CKIT-042 board. I2C SCL; I2C SDA; XRES; VTARG; GND

   

2. set up the CapSense Tuner communication parameters (keep corresponding with EZI2C component).
I2C address:0x08;      Sub-address:1-Byte;     I2C Speed:400khz;      Power: 5.0v (CY8CKIT-042 set the jump J9 to select 5v)

   

3. Click connect. connecting successfully, then click start, there can see the 4850mv power on in the Tuner GUI and the POWER led light on in the CY8CKIT-042 borad.

   

4. Touch the CapSense, observe the result. It can work normally about 10s, the POWER led light off automatic.

   

5. Change the Tuner communication parameters
I2C address:0x08;      Sub-address:1-Byte;     I2C Speed:400khz;      Power: 3.3v (CY8CKIT-042 set the jump J9 to select 3.3v)
It can work well.

   

I want to know that the CapSense Tuner tool whether can work with 5v? And MiniProg3 supply 5v power whether ok?
But I used the KitProg to debug it . it's OK no matter what 3.3v or 5.0v.

   

What's more, I used MiniProg3 supply for kit board and communication with I2C Control Panel tool. It can work normally for a while, then the kit board power off automatic.

   

Excepting reply.

   

Joan

0 Likes
Reply
3 Replies
Esteemed Contributor II

Welcome in the forum, Joan. We do not see  very often Cypress employees asking questions here 😉

   

Please try to use a different Miniprog3 and / or a shorter USB cable. Maybe there is a power overload problem.

   

 

   

Bob

0 Likes
Reply
Employee

Hi Bob,

   

Thanks for your reply in time. I searched the reference materials yesterday, then I found the forum and posted a post. The forum is just for customer?I'm not familiar with it.I have got some effective suggestions from Indian colleague and I will try. I have tried to use different MiniProg3, it's no effect. About using the shorter USB cable, it can works well with CY8CKIT-042. But the customer's kit board doesn't have the usb interface. 

   

I'm so happy to receive your reply.

   

Joan

0 Likes
Reply
Esteemed Contributor II

Your Miniprog3 is connected with a USB-cable to the board. There have been users here in the forum having problems with longer / bad cables. Changing the cables made the issues disappear.

   

Here in the CDC (Cypress Developer Community) usually users ask question which are answered by other members or by Cypress employees (when nobody else has got a solution).

   

 

   

Bob

0 Likes
Reply