cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

New Contributor

Hello

I see in the documentation that the microcontroller is
compliant with SAE J2602. My application requires LIN 2.0 and SAE J2602
Compliance. Can you confirm that by checking the as in the screenshot attached,
the code will be compliant with the J2606 compliance? Also, I read in the
manual that For PSoC 4 devices only, the LIN
Slave Component is certified by the C&S group GmbH based on the standard
protocol and data link layer conformance tests. A complete certification report
can be made available on request. Does this certification include compliance to
SAE J2606 Compliance? If yes, how can I procure this data?


0 Likes
Reply
1 Solution
Moderator
Moderator

Hi,

The LIN component (vs 5.0) supports fully compliant J2602-1 specification. You need to enable this in the component (from you screenshot it appears to be okay). But the certification was not done for LIN 2.0 (it was done for other version Lin 1.3,2.1, 2.2 ), so you may need to get the certification for compliance test done at your end. For the conformation test of other versions, you may contact Cypress Local sales representative. Please refer this KBA link: Getting Started with PSoC® 4 LIN Slave Component - KBA210346

Thanks!

Ashish

View solution in original post

0 Likes
Reply
1 Reply
Moderator
Moderator

Hi,

The LIN component (vs 5.0) supports fully compliant J2602-1 specification. You need to enable this in the component (from you screenshot it appears to be okay). But the certification was not done for LIN 2.0 (it was done for other version Lin 1.3,2.1, 2.2 ), so you may need to get the certification for compliance test done at your end. For the conformation test of other versions, you may contact Cypress Local sales representative. Please refer this KBA link: Getting Started with PSoC® 4 LIN Slave Component - KBA210346

Thanks!

Ashish

View solution in original post

0 Likes
Reply