cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

New Contributor II

Hi people,

I get this error when executing my project, which is based on a BLE connection where I use the devices shown in the attached photo.

I tried to uninstall and reinstall PSoC Creator but it still gives me the same bug.

Any ideas to fix it? It is the only mistake it gives me.

Greetings

0 Likes
Reply
1 Solution
Esteemed Contributor

Hi,

I tried to build your project.

The last 4 lines were.

====================

.\CortexM0\ARM_GCC_541\Debug\main.o:(.bss+0x0): multiple definition of `deviceConnected'

.\CortexM0\ARM_GCC_541\Debug\BLE_APP.o:(.bss+0x0): first defined here

collect2.exe: error: ld returned 1 exit status

The command 'arm-none-eabi-gcc.exe' failed with exit code '1'.

--------------- Build Failed: 10/27/2019 20:49:24 ---------------

====================

This error message suggests that both you and the library have identifier named "deviceConnected"

In your main.c there were two lines which has "deviceConnected".

So I changed "deviceConnected" to "device_connected" in your main.c.

And now your project is build-able.

Attached is modified project of yours 😉

moto

View solution in original post

3 Replies
Esteemed Contributor

Hi,

I think that there must be some error message(s) before that line.

Did you see the "output" tab?

Seeing your attached picture, it seems that the pin DHT has "Hardware Connection" but nothing is connected to it.

If you open the pin configuration of DHT (by double-clicking the symbol) you can uncheck that option.

So that the pin is for software control only, then (I hope that) the compile will be done.

So I tried to duplicate your problem.

Since you did not specify the device, I selected PSoC 4200 BLE.

Then enter a schematic like below.

000-schematic.JPG

I have not write any code, so main.c was in the original shape.

Then I tried to build this and result was

In the Notice List

001-Notice_List.JPG

In the Output

002-Output-tab.JPG

So the messages were different from yours.

May be you have other problems or your message output settings are different from mine.

Anyway, then I double-clicked the DHT pin to configure.

Note: at this point "HW connection" is checked.

003-pin-config-1.JPG

So I unchecked "HW connection"

004-pin-config-2.JPG

Now my schematic looks like

Note: no external connection pin in "DHT"

005-schematic.JPG

Then I tried to compile the project.

And the compile succeeded.

006-Compile-done.JPG

If the above does not fix the problem, could you attach the project to this discussion topic?

To do so,

In the Workspace Explorer

Select the project as the top by "Set as top.."

Build > Clean <project>

Project > Archive Workspace/Project ...

Attach the resulting zip

moto

0 Likes
Reply
New Contributor II

Hi Motoo,

I attached you the project.

I am using PSoC 4200 BLE, DHT pin is the data to the DHT22 sensor.

I use I2C to show the result of the DHT22 sensor at the LCD 16x2.

Try to build the project and tell me what do you obtain.

I am using PSoC 4200 BLE, DHT pin is the data to the DHT22 sensor.

0 Likes
Reply
Esteemed Contributor

Hi,

I tried to build your project.

The last 4 lines were.

====================

.\CortexM0\ARM_GCC_541\Debug\main.o:(.bss+0x0): multiple definition of `deviceConnected'

.\CortexM0\ARM_GCC_541\Debug\BLE_APP.o:(.bss+0x0): first defined here

collect2.exe: error: ld returned 1 exit status

The command 'arm-none-eabi-gcc.exe' failed with exit code '1'.

--------------- Build Failed: 10/27/2019 20:49:24 ---------------

====================

This error message suggests that both you and the library have identifier named "deviceConnected"

In your main.c there were two lines which has "deviceConnected".

So I changed "deviceConnected" to "device_connected" in your main.c.

And now your project is build-able.

Attached is modified project of yours 😉

moto

View solution in original post