cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4 MCU

Anonymous
Not applicable

Hi All,

I'm trying to use the 8-channel ADC_SAR_SEQ on the CY8CKIT-042-BLE development kit. I can get appropriate ADC measurement readings for the first 4 channels, but the ADC cannot read voltages 0-995mV on channels 4 (P3[4]) & 5 (P3[5]), and cannot read voltages 0-311mV on channels 6 (P3[6]) & 7 (P3[7]). I am using a benchtop supply to feed the input voltage directly into the ADC_SAR pins through (P3[0]-P3[7]).

I'm using the following ADC configurations:

Vref Select: External Vref

Vref Value: 2.5V

Single ended negative input: Vref

Single ended result format: Unsigned

Clock source: Internal

All 8 channels use 12-bit resolution single-ended mode

Acq time: 1.5us

Conversion time 16us

Do you have any idea what could be preventing the last 4 channels from reading the low voltages? Thank you very much for your time!

0 Likes
1 Solution
JoMe_264151
Expert II

Have a look at the kit's schematic files. Probably your input pins are already connected to some caps or other hardware. Schematics have been installed on your PC when you installed the kit files.

Bob

View solution in original post

2 Replies
JoMe_264151
Expert II

Have a look at the kit's schematic files. Probably your input pins are already connected to some caps or other hardware. Schematics have been installed on your PC when you installed the kit files.

Bob

View solution in original post

Anonymous
Not applicable

Bob,

Thanks for your response. It turns out P3_4 & P3_5 are tied to I2C_SDA & I2C_CLK while P3_6 & P3_7 are tied to the Green & Blue LEDs. I really appreciate your help.

-Junya

0 Likes