cancel
Showing results for 
Search instead for 
Did you mean: 

Nor Flash

Anonymous
Not applicable

We’re using S25FL128SAGMFV000 NOR flash memory in our "ECM" application. The ECM is not powering-up and after investigation and analysis we found that the NOR flash memory corruption CR1 “configuration registers” and OTP 0 bits. Any idea what could be the cause of this failure?

Here is the memory readout data:

Thanks a lot

0 Likes
Reply
1 Solution
Moderator
Moderator

Hello Aejaz,

Are you trying to reproduce the register corruption?

If so, you would need to do power loss during the WRR. If you try enough times, you should be able to see it.

Thank you

Regards,

Bushra

View solution in original post

0 Likes
Reply
4 Replies
Moderator
Moderator

Hello,

Thank you for contacting Cypress Community Forum. We have received your inquiry and currently reviewing the issue. We will get back to you as soon as we find the resolution.

Have a wonderful weekend

Regards,

Bushra

0 Likes
Reply
Moderator
Moderator

Hello,

Please refer to KBA for sudden power loss. If you still have question, please let me know

https://community.cypress.com/docs/DOC-13833

Thank you

Regards,

Bushra

0 Likes
Reply
Anonymous
Not applicable

Hi Bushra,

Thanks for your feedback. we're trying as per the KBA sudden power loss application note . We made some changes and adjust the "WRR Write Time" Typ.140msec & Max.500msec as mentioned in datasheet but still we're enable to reproduce the phenomenon. do you have any idea how we can reproduce it.

Thanks

Best Regards,

Aejaz

0 Likes
Reply
Moderator
Moderator

Hello Aejaz,

Are you trying to reproduce the register corruption?

If so, you would need to do power loss during the WRR. If you try enough times, you should be able to see it.

Thank you

Regards,

Bushra

View solution in original post

0 Likes
Reply