cancel
Showing results for 
Search instead for 
Did you mean: 

ModusToolbox General

New Contributor II

I'm running a Mac OSX 10.14.4

I installed Modus Toolbox, and told me it needed XCode.  I installed XCode, and removed original ModusToolbox, and reinstalled Modus Toolbox.

It now tells me "Cannot run program "/Applications/ModusToolbox_1.1/tools/modus-shell-1.0/bin/make" (in directory "/var/folders/py/hnmmy0m14v97z_0xk9nszk2w0000gp/T"): error=2, No such file or directory"

The executable Make is not in the above mentioned folder.

What is causing this?  I've tried several reinstalls of Modus Toolbox.

Thanks,

Gary

0 Likes
Reply
1 Solution
Employee

Hey Gary,

Sorry the install is not going smoothly .  I got this from one of our engineers running on the Mac.  Maybe it will be helpful.

It could be just as easy as making sure you run the IDE once to get all the links set up.

=============== Begin Include ==========

pastedImage_0.png

===== End Include ==================

Let us know if that helps.

--Matt

View solution in original post

7 Replies
Moderator
Moderator

Hello Gary,

You need the make and xcode packages while installing ModusToolbox on MacOS. Please follow the installation guide which explains how to install ModusToolbox correctly here: https://www.cypress.com/file/455216/download

Regards,

Dheeraj

0 Likes
Reply
New Contributor II

Hi Dheeraj,

Thanks for the quick reply!

I notice this in the installation guide:

I've looked in the App Store, and googled, but cannot find any help on

where to find these packages.  I found Get Perl in the App store, but

don't think that's what is indicated in the notes above.

I installed XCode from the App Store, and it installed 10.2.1

An older reference said "the command line tools are no longer bundled by

default, and there is no /Developer anymore. To install them, open

Xcode, go to Preferences -> Downloads -> Components -> Command Line

Tools. This should install make, gcc etc."

However, this is not valid guidance for 10.2.1

Can you point me in a direction?

Thanks for your help!

Take Care,

Gary

0 Likes
Reply
Employee

Hey Gary,

Sorry the install is not going smoothly .  I got this from one of our engineers running on the Mac.  Maybe it will be helpful.

It could be just as easy as making sure you run the IDE once to get all the links set up.

=============== Begin Include ==========

pastedImage_0.png

===== End Include ==================

Let us know if that helps.

--Matt

View solution in original post

New Contributor II

Well, I finally gave up trying to get this working on Mac OSX, and built a new Ubuntu 18 box.  Things were going along well with ModusToolbox, as I thought I was close to being able to make and download one of the sample projects for the WiFi-BT PSOC 6 kit, when I got stuck several hours ago at the KitProg2 fw update problem.

Essentially, I cannot get the fw-loader to execute.  Here's a screen shot:

pastedImage_0.png

I am a bit rusty in Linux, but I'm in the bin folder where the 38.2KB 'fw-loader' file is present, yet when I try to execute the command, you can see the error is 'fw-loader' not found.  In desperation, I set the permissions to '777' - still no help.

(BTW, I found where I needed to press SW3 while connecting the USB cable, and I have LED4 solid and LED2 blinking, which I believe means I'm in bootloader mode, ready to receive the KitProg3 fw update.  Do I at least have that right?)

I'm sure this is basic, but I am stuck.

Can you help?

Many Thanks!

0 Likes
Reply
New Contributor II

Nevermind.  Looks like I found the problem!  Had to add './' to the fw-loader command, and I was able to do the update.

Thanks anyway!

New Contributor II

...and, I understand why I needed to put ./ in front of the fw-loader command: even though I was in the current folder, Linux always looks to the PATH for program names, unless I tell it use current folder with the './'

New Contributor II

In principle yes, but with me not „./“, but only „.\“.

Helmut

Von: Matt Landrum

Gesendet: Montag, 13. Mai 2019 19:43

An: Helmut Mielenz <service@mielenz-ctg.de>

Betreff: Antwort auf Just installed Modus Toolbox - cannot create first Application als hilfreich markiert

<https://community.cypress.com/?et=watches.email.outcome> Cypress Developer Community

Just installed Modus Toolbox - cannot create first Application

Matt Landrum <https://community.cypress.com/people/MattL_01?et=watches.email.outcome> hat die Antwort von user_500162769 <https://community.cypress.com/people/user_500162769?et=watches.email.outcome> zum Thema Just installed Modus Toolbox - cannot create first Application <https://community.cypress.com/thread/45614?et=watches.email.outcome> als hilfreich markiert. Gesamte Antwort anzeigen <https://community.cypress.com/message/195617?et=watches.email.outcome#195617>

0 Likes
Reply
Top labels