cancel
Showing results for 
Search instead for 
Did you mean: 

ModusToolbox General

New Contributor II

Hi,

I have been following the instructions in section 5.4 of (https://www.cypress.com/file/512716/download ) to create a custom BSP for my own custom board that is designed based on CY8C6247BZI-D54. I created a custom BSP called ELSBSP based on CY8CKIT-0620WIFI-BT. Then I built a Blinky LED example by simply setting the GPIO in Device Configurator and added a few line in the main.c . I'm able to successfully compile the program but I can't flash the board using MiniProg4. I get the following error every time that I try to program the board:

pastedImage_2.png

After expanding the details, I see this:

Program file does not exist

~\mtw\test6\ELS_FW\build\CY8CKIT-062-WIFI-BT\Debug\mtb-example-psoc6-empty-app.hex not found

~\mtw\test6\ELS_FW\build\CY8CKIT-062-WIFI-BT\Debug\mtb-example-psoc6-empty-app.hex not found

~\mtw\test6\ELS_FW\build\CY8CKIT-062-WIFI-BT\Debug\mtb-example-psoc6-empty-app.hex not found

It looks like it is looking at wrong folder (CY8CKIT-062-WIFI-BT) instead of ELSBSP to find the hex file.

pastedImage_7.png

I double checked my make file and that is targeting the right BSP.

pastedImage_5.png

Please advise.

Thanks.

0 Likes
Reply
1 Solution
Moderator
Moderator

Hi AnA_4675486​,

Although the makefile is updated the launches might not be reflecting this change which is why I think it is still searching for the previous hex file. Can you click on Generate Launches option in the Quick Panel and then try to program the device?

These threads on similar issues might help you -

Re: I was able to build - but cannot load/execute

Re: Custom BSP

Thanks and Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B

View solution in original post

2 Replies
Moderator
Moderator

Hi AnA_4675486​,

Although the makefile is updated the launches might not be reflecting this change which is why I think it is still searching for the previous hex file. Can you click on Generate Launches option in the Quick Panel and then try to program the device?

These threads on similar issues might help you -

Re: I was able to build - but cannot load/execute

Re: Custom BSP

Thanks and Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B

View solution in original post

New Contributor II

That was a good hint. A combination of "Refresh Quick Panel" and "Generate Launches" solved my problem.

0 Likes
Reply
Top labels