Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

ModusToolbox Bluetooth SDK

prpr_4759451
New Contributor

Hi All,

As per the following link Cypress BLE Mesh works Bluetooth 5.0, And it is Bluetooth 5 qualified.

https://www.cypress.com/products/bluetooth-low-energy-mesh

Can you please suggest me any Cypress BLE Mesh example which uses BT 5.0.

Thanks and regards

Pradeep

0 Likes
1 Solution
DheerajPK_41
Moderator
Moderator

Hi,

BLE Mesh only requires 4.0 Bluetooth as per the current Mesh Spec. None of the Bluetooth 5.0 features are currently allowed by the spec. For new features of Bluetooth 5.0, such as Advertising Extensions, the mesh spec needs to get updated. This is currently planned for Mesh 2.0.

Thanks,

-Dheeraj

View solution in original post

0 Likes
3 Replies
DheerajPK_41
Moderator
Moderator

Hi,

I would suggest you to start by installing and experimenting Modustoolbox Software Environment.

Link: https://www.cypress.com/products/modustoolbox-software-environment

For the code example, Please visit the cypress Github page.

Link: Cypress Semiconductor Corporation · GitHub​    (Eg: CYBT-213043-MESH demo code examples)

Mesh supported Bluetooth chips (Eg. 20819, 20719, ...) are Bluetooth 5 spec qualified, and it support mesh specification v1.0.

Please check below links for more details:

Thanks,

-Dheeraj

0 Likes
prpr_4759451
New Contributor

Hi Dheeraj,

Thanks for the reply.

I understood chip 20819, 20719, etc, are Bluetooth 5 spec qualified and support BLE mesh.

I am just asking, is there any BLE Mesh example available, which stack is based on Bluetooth 5 not Bluetooth 4.2 or previous version.

I have already seen all these examples, kindly suggest me any BLE mesh example that works upon Bluetooth 5.

0 Likes
DheerajPK_41
Moderator
Moderator

Hi,

BLE Mesh only requires 4.0 Bluetooth as per the current Mesh Spec. None of the Bluetooth 5.0 features are currently allowed by the spec. For new features of Bluetooth 5.0, such as Advertising Extensions, the mesh spec needs to get updated. This is currently planned for Mesh 2.0.

Thanks,

-Dheeraj

View solution in original post

0 Likes