cancel
Showing results for 
Search instead for 
Did you mean: 

ModusToolbox Bluetooth SDK

New Contributor II

Since my other thread here was closed, this is intended to be a continuation.

DheerajP_41​ I have attached some ADB logs from two scan attempts. In both cases, all 4 devices showed up in the app, but in each case at least 1 didn't have an associated name, it just showed the UUID. Looking at the logs, I see that it does properly discover the name, so not sure why it's not showing up in the app.

This is with version v2.1.0 of the wiced bt sdk. I am having much better luck with this version as opposed to the previous version (I think i was using 2.0.0 when I first tried this experiment). With the latest, I was able to eventually get them all to provision properly, although some took a couple attempts.

0 Likes
Reply
1 Solution
Moderator
Moderator

Hi,

Thank you very much.

In mobile APP GUI: "at-least 1 didn't have an associated name, it just showed the UUID"

In ADB logs: "Looking at the logs, I see that it does properly discover the name"

Based on your test and above observation, I think it can be a mobile app GUI issue. 

Or if it takes more time for scanning (extended/active scan) app may skip the name and only get the UUID for making a connection.

But it should not block or disturb any other feature. Otherwise please provide us the information.

We will inform this to our software team to understand the issue.

Thanks,

-Dheeraj

View solution in original post

1 Reply
Moderator
Moderator

Hi,

Thank you very much.

In mobile APP GUI: "at-least 1 didn't have an associated name, it just showed the UUID"

In ADB logs: "Looking at the logs, I see that it does properly discover the name"

Based on your test and above observation, I think it can be a mobile app GUI issue. 

Or if it takes more time for scanning (extended/active scan) app may skip the name and only get the UUID for making a connection.

But it should not block or disturb any other feature. Otherwise please provide us the information.

We will inform this to our software team to understand the issue.

Thanks,

-Dheeraj

View solution in original post