cancel
Showing results for 
Search instead for 
Did you mean: 

Clocks

dakr_1332071
New Contributor

Hi All,
We purchased a CY3679 clock generator eval board and am trying to output a 100 MHz clock on single ended port 15.  I successfully generated the JEDEC file, but when I try to program it I get the following error.

Info: JEDEC file generation completed. Project_00.jed created.

Info: Programming started for Project_00 at 07/05/2020 14:12:40

Error: Programming operation checking, status - Error: Set I2C voltage -

I can't find any settings for I2C voltage.

Previously, I was getting a different error:

Error: Programming operation checking, status - Error: Open port - KitProg version Expecting 2.21, but found 2.18.

I found a discuss that told me to run C:\Program Files (x86)\Cypress\Programmer\Service>CyMiniProg3Service.exe /service

After doing that I now get the I2C error.

Thanks in advance for your help.

D-

0 Likes
1 Solution
PradiptaB_11
Moderator
Moderator

Hi,

Can you follow the steps listed in the KBA to update your KitProg firmware. It should remove the update error.

Updating Firmware in Clock Kits – KBA220548

Thanks,

Pradipta.

View solution in original post

0 Likes
3 Replies
PradiptaB_11
Moderator
Moderator

Hi,

Can you follow the sections 2 and 3 of the kit user guide (link below). You can take screen shots for various configuration, results and output and share the result with us(you can also attach your Clock Wizard project). It will help us understand better if your kit is working or not with the defined examples. Once the kit works we can support you for your custom profiles.

https://www.cypress.com/file/157836/download

Thanks,

Pradipta.

0 Likes
dakr_1332071
New Contributor

Hi Pradipta,

I tried the steps you recommended. I also tried uninstalled and re-installed the software. I then ran the example project CLK GEN.cpj I first ran that with ClockWizard 2.0 but when I clicked on Generate the program simply closed. So I then ran the update utility and installed version 2.2.

I made no changes to the configuration and the message indicates the JEDEC file was successfully created. When I then click Program I get the error you can see from the screen capture. If I click Program again I then get an I2C error message as you can see in the 2nd screen capture. I also don’t see any LEDs flashing on the board while attempting to program. There are two green LEDs that remain constant on.

What do you suggest next? Thanks for your help.

David Kramer

DMK Engineering Inc.

310-544-1222 x101

0 Likes
PradiptaB_11
Moderator
Moderator

Hi,

Can you follow the steps listed in the KBA to update your KitProg firmware. It should remove the update error.

Updating Firmware in Clock Kits – KBA220548

Thanks,

Pradipta.

View solution in original post

0 Likes