5 Replies Latest reply on Nov 13, 2013 4:16 PM by HeLi_263931

    Bootloaded application works differently form MiniProg programmed application

      I am developing a firmware for a custom board based on PSoC 3.


      I am currently using PSoC Creator 3.0 updated at last version with all the components updated to their last version.


      I decided to try to implement bootloader capability to my board to be able to distribute new firmware updates to customers without the need to have a MiniProg.


      Following the Application Note AN68272 I was able to upload new firmware into my board through UART and I was happy to see that everything seemed to work fine. When I tried to perform a complete check about all the functionality of my firmware, I discovered that some of the pins were not properly driven.


      In my specific case I use a PWM block to drive 2 DC motors with 2 H-Bridge. When I use the same application updated directly through MiniProg programmer, the two motors work fine, but when I update the firmware using bootloader capability, one of the two motors does not move at all.




      the bootloader block has the "Bootloader application validation" checkbox checked and the "Fast bootloadable application validation" checkbox unchecked. I use the bootloader host program included in PSoC Creator 3.0 to upload my application, and I also tried to verify the uploaded application (with the bootloader host application) and everything seems to be ok.




      Does anybody experienced similar problems? Is there someone who can give me some advicecs or other attempt to do?


      Thank you very much.