1 2 Previous Next 15 Replies Latest reply on Sep 15, 2014 2:53 PM by JoMe_264151

    Checksum Failed



      when I try to program a code example on multifunction expansion card with FTSK programmer, I always receive the next programming log:

          Programming Terminated   
          ===> Checksum Failed   
          Doing Checksum   
          Doing Protect   
          Programming Succeeded   
          Programming Starting   
          Erase Succeeded   
          Silicon: 0038, Family/Die: 15, Major Rev: A   
          >>>Program Requested   
          PSOC seems is programed correctly but this error always appears.   
          Can someone help me?   
        • 1. Re: Checksum Failed

          This forum software is a bit weired, so can it be that we have to read the lines from bottom up?


          If so, it seems to be correct: The last thing you (the programmer) do is burning some last fuses, so that the contents cannot be red out ("protect") This implements that a checksum cannot give a correct result since nothing meaningful can be red back from that point on. Solution? Try to disable check-summing the device.





          • 2. Re: Checksum Failed

             Thanks for reply.


            How Can I disable checksum?

            • 3. Re: Checksum Failed

              Don't know exactly, did you try to disable verification in the PSoC programmer ?





              • 4. Re: Checksum Failed

                 Hi Bob,


                Yes I try to disable verification, but the error appears.


                I think this error could be caused by 'Doing Protect' action, after programation is corfirmed. Is posible disable it?


                I dont find where.





                • 5. Re: Checksum Failed

                  There is a file named "flashsecurity.txt" shown in the workspacwe explorer. Edit this file accordingly to unprotect your flash-areas if you want to.





                  • 6. Re: Checksum Failed
                        Hi Bob,   
                        I have detected the problem but is very strange.   
                        When I'm using the computer with a high comsuption of resources (like compiling a linux kernel) and then I try to program a PSoC, checksum process is OK, but when resources are free, checksum fails.   
                        It seems be fine when works slowly.   
                        Is posible reduce the programming velocity ? Or do some similar?   
                    • 7. Re: Checksum Failed

                      This looks a bit weired now, better try to file a technical case (under "Support -> Technical Support -> Create a Case" at the top of this page) to get some Help from Cypress directly.





                      • 8. Re: Checksum Failed

                        This looks a bit weired now, better try to file a technical case (under "Support -> Technical Support -> Create a Case" at the top of this page) to get some Help from Cypress directly.





                        • 9. Re: Checksum Failed

                          Yes, this does sound weird.. 




                          Do you have a spare system which you use to program your device? That will help you make sure it's the PC/software that is causing the problem.







                          • 10. Re: Checksum Failed

                            Did you ever find out what was causing the problem?  I am getting the same error. Sometimes, the device does get programmed, but sometimes I get the error.

                            • 11. Re: Checksum Failed

                              What hardware, which board, which PSoC, which programmer and which software version are you using?





                              • 12. Re: Checksum Failed



                                I have the same problem, the following message appears


                                Program Finished at 12:42:25 ص                                


                                                                                              | Programming Terminated


                                                                                              | ===> Protect Failed


                                                                                              | Doing Protect


                                                                                              | Programming Succeeded


                                                                                              | Programming Starting


                                                                                              | Erase Succeeded


                                Device set to CY8C24423A at 12:42:20 ص                         | 4096 FLASH bytes


                                Device Family set to 24x23A at 12:42:20 ص                    


                                                                                              | Automatically Detected Device: CY8C24423A


                                Program Requested at 12:42:19 ص                              

                                • 13. Re: Checksum Failed

                                  You do not have a checksum faillure, but a protection faillure.


                                  I would suggest to


                                  First: switch off all protection completely and verify programming and project working correctly.


                                  later: start switching on protecction which afaik cannot be verified (due to the protection)





                                  • 14. Re: Checksum Failed

                                     I as well get this


                                    Verification of "Protect Area" is FAILED!


                                    Programming Terminated


                                    ===> Protect Failed


                                    Doing Protect

                                        I used to have the checksum fail until I turned everything in flashsecurity.txt to "U" or unprotected. I've also tried changing which aquire mode I'm in and have verification off. Any ideas?   
                                        I'm using Mini Prog3/1229DD000931   
                                    1 2 Previous Next