7 Replies Latest reply on Aug 20, 2015 5:20 AM by userc_41056

    PSoC Designer 5.4 Installation problem

      I have repeatedly tried to install the package on my XP SP3 box and just at the point where I am informed that the installation has completed, my next click brings up a message telling me that the Update Manager is not installed. The installation apparently terminates with no icons or shortcuts being created save for "CyInstaller for PSoC Designer 5.4" appearing in the Start Menu. How do I get around this roadblock?

        • 1. Re: PSoC Designer 5.4 Installation problem

          You probably tried installation with admin rights already?





          • 2. Re: PSoC Designer 5.4 Installation problem

            Yes. My account on my machine belongs to the admin group. This is a one-off anomaly and appears to be bad karma for a particular instance. Everything else works correctly. I have tried the install several times. I'll either figure it out (as I've always had to do with everything else) or just use it on my W8.1 laptop (on which the install proceeded correctly). Thanks for the reply.

            • 3. Re: PSoC Designer 5.4 Installation problem

              Does the executable appear in its program folder such that you can simply create


              a shortcut to that ? Not exactly elegant way to do an install but all things else considered


              might get you up and running.




              Regards, Dana.

              • 4. Re: PSoC Designer 5.4 Installation problem

                The executable is not present. The only application appearing in the program files folder is (incredibly) "psocdesignerinstaller.exe" in the directory tree "Cypress\PsoC Designer\5.4\Updater\". I had a crack at installing 5.4SP1 this evening but maybe I had already tried that particular version as the result was the same. The installer did give me the option to uninstall so that says something.


                I now have a problem on my 8.1 laptop which didn't come to light until I tried to Build the project (that I finally got to Make successfully on my work machine today after installing 5.4SP1 - had a standard library file-finding issue on this machine prior to today's install/upgrade/repair. I consider that finally being able to program a target device and so complete an assignment to be a matter of good luck Hopefully the object code is free of build/compilation errors. The work machine is a dual-core Win7 box).


                The error message on my laptop: "*** No rule to make target 'D:\CYPRESS\PSoC1\PSoC'. needed by 'lib/obj/alarm_inv.o'. Stop.  Not very helpful really. This occurred at the Make stage of the process.


                While I appreciate the modern tools that are being created to make chips as easy to use as possible (and thereby generate silicon sales) it is tempting at times to revert to old ways of doing things - I was writing assemblers 30 years ago. Complexity is not without its drawbacks. I am not a fan of compilers generally.



                • 5. Re: PSoC Designer 5.4 Installation problem

                  Create a MyCase and get in contact with Cypress directly. At top of this page click on "Design Support-> Create a Support Case", leave a link to this thread and your phone number and timezone.


                  Having written compilers myself, I believe in their usability, but a permanently failing installation of an IDE can cost nerves -and coffee ;-)





                  • 6. Re: PSoC Designer 5.4 Installation problem

                    Hello Malcom Watts,


                    May I create the technical support case on behalf of you regarding this issue? Please confirm.


                    Thanks and Regards,


                    Ramesh B,

                    • 7. Re: PSoC Designer 5.4 Installation problem

                      Thankyou for your offer. I'm going to try 5.0 SP6 on both machines if I can locate it. The version doesn't really matter so much. It's possible the Windows installer is incompatible. I do have a very early (2006-ish) version of Designer which came with the Miniprog (1?) that works OK and am aware that there may be the odd bug in it. I'm more than half-convinced that the problems are some kind of software clash. It is interesting that 3 machines exhibited 3 different kinds of behaviour with the same version.