0 Replies Latest reply on Mar 30, 2017 5:22 AM by DeKe_2275631

    CSW Signature Error


      I've encountered a recurring error while trying out MSC driver of USB Host example on FX3 Development Kit (CYUSB3KIT-001).
      (AN77960 was my guide)


      I've tried four different flash drives, and only one of them (2GB) got me response described in AN77960. One (2GB) got me only "Host connect event received" and "Host disconnect event received", the other two(8GB each) gave response shown below.


      Host connect event received
      Device descriptor received
      Device address set
      Config descriptor received
      MSC device detected
      Host connect event received
      Application start failed with error: 74.


      As it turned out after some debugging, error occurs because of an invalid CSW Signature
      in CyU3PReturnStatus_t CyFxMscCheckCSW (uint8_t *csw) where csw[12] equals 1 in both cases.


      csw[12] represents bCSWStatus field of CSW, thus bCSWStatus == 1 means  "Command Failed", which gives me... no new information.
      (http://www.usb.org/developers/docs/devclass_docs/usbmassbulk_10.pdf page 14)
      All the drives are readable from Windows. I've tried formatting, just in case, it didn't help.
      (Is there any list of flash drives compatible with FX3 Host Controller, maybe? If there should be one.)


      Any tips or directions to the solution would be very much appreciated.