3 Replies Latest reply on Mar 30, 2020 1:08 PM by BoTa_264741

    Workspace not being saved


      I am running Creator 3.3 SP2 on 2 machines. The IDE was working fine on both machines (Both Windows 10, 64 Bit).


      Recently, one of the installations has stopped saving the IDE settings.


      Every time I start the IDE the window is not maximized, the Recent list is empty, the text has defaulted to very small (size 8).


      Then I load a project, set the fonts and window sizes,  compile code ok but when I close and reopen the IDE, it reverts back to that default state. (Very frustrating).


      Anyone else had this issue or know how I can fix it?





        • 1. Re: Workspace not being saved

          Found it. I looked at the creator xml config file and it had content nullnullnull...


          I deleted this config file and ran the program and it works ok now. Must have got corrupted somehow?

          • 2. Re: Workspace not being saved

            I had a similar problem with PSoC Creator 3.3 CP3: each time I tried to build the project, cydsfit.exe flagged an error when it was attempting to synthesize a custom component in my PSoC Creator project.


            The error message was of the type:

            The instance '....', of component MY_COMPONENT, contains an error. Component MY_COMPONENT is not available.

            Component security is disabled for the project <my_component_project>. If you trust the author of the project and wish to allow this component to run the code on your computer during the design process, select Tools->Options->Design Entry->Component Security and add the project folder to the approval list.

            And this despite the fact that I "allowed" the custom component in Tools > Options > Design Entry > Component Security (i.e. I added its project folder to the list of trusted projects).


            It turned out not being a problem with a corrupted project nor a corrupted PSoC Creator.

            I noticed that the settings entered in Tools > Options > Design Entry > Component Security were never saved, and also all the other Workspace settings.


            After some digging I found that PSoC Creator 3.3 stores all that information in the folder (in the case of PSoC Creator 3.3 and Windows XP):

            C:\Documents and Settings\<user>\Local Settings\Application Data\Cypress Semiconductor\PSoC Creator\3.3\

            (where <user> is the user login name on that PC and subfolder \3.3\ refers to PSoC Creator version 3.3: fortunately every PSoC Creator uses its own subfolder).

            The content (files, subfolders) of that folder must have been corrupted.


            It was enough to quit PSoC Creator, delete that folder and restart PSoC Creator.

            The folder will be recreated and "Build" runs without errors.


            By the way, the action that triggered all this mess was that I once cancelled a project build in progress (by pressing ctrl+break) because I had forgotten something. This seems to be a bug with PSoC Creator 3.3. Therefore my advice: never interrupt a build in progress. It's better to wait until it finishes even if you are going to ignore the output.

            2 of 2 people found this helpful
            • 3. Re: Workspace not being saved


              Same happened to my Creator after Keil registration expiration. Upon re-setting Keil registration all component security was disabled and can't be enabled, a Startup page popped-up on every startup etc. - Creator couldn't keep Options.

              Deleting content of a folder

              "C:\Users\<usename>\AppData\Local\Cypress Semiconductor\PSoC Creator\4.0"

              solved this issue.

              Thanks again for solution!