6 Replies Latest reply on Mar 13, 2020 7:06 PM by JiHu_4622996

    miniprog3 problem


      Hi, my miniprog3 connects to CYkit 035 board with 5 pin SWD, normal. USB connect to CYkit050 board, download hex file, normal. Can monitor Power via power supervision tool.

      However, I tried to download hex file via 10 pin SWD in CYkit 050, the 12V power on and VDDD/VADJ 5V. The LEDs on board turn off quickly and turn on soon.


      Next, I try to get back to the initial state, but in the power supervision tool it shows No IIC device found & IIC address NAK.


      Finally, only ststus LED in miniprog3 shines when connecting USB to PC(other LED shines quickly but turn off soon).  Is it normal and how to fix the IIC address problem?



        • 1. Re: miniprog3 problem

          Hi JiHu_4622996,


          Can you program CY8CKIT-050 using the on board DVKProg?


          my miniprog3 connects to CYkit 035 board with 5 pin SWD, normal

          If MiniProg is able to program other devices then there might not be any issue with the MiniProg.

          Are you using PSoC Programmer to program the device? Can you confirm that you have selected 10 pin option? Can you please share a screenshot of PSoC Programmer after connecting the device?


          Also, can you confirm that the connections from MiniProg and the target device is as shown in the snapshot below?


          Rakshith M B

          • 2. Re: miniprog3 problem

            Hi ,thank you for replying fast!


            I connect miniprog3 to CY050kit 10 pin SWD as your guidance, 10p selected, no external power supply. However, it seems the miniprog cannot supply power for the test board. Besides, VDDD=3.3V and VADJ=5V.


            • 3. Re: miniprog3 problem

              Hi jihu_4622996,



              In the PSoC Programmer log (from the screenshot that you have shared) I do not see anything mentioned about powering the device.

              Did you try clicking on Toggle Power icon (shown in the image below)? Please let me know if you are able to program the device after this.



              Rakshith M B

              • 4. Re: miniprog3 problem

                Hi Rak,


                As your guidance, push toggle power button but the ui crashes and tried many times the same(voltage: still low).


                The ststus LED shines and Target power (Red) turns on, no LED in the CY050kit shines. Looks like the power still can not get to the main board. 0306_1.jpg


                • 5. Re: miniprog3 problem

                  Hi jihu_4622996,


                  I tried the same steps with one of the PSoC 5LP Kit and I was able to reproduce the same issue. Upon further debugging I found that the VDDA was not at 3.3V even though the Kit was powered with 3.3V. So, I shorted VDDA and VDDD by removing R23 (loaded by default) and loading R30 as mentioned in Section Low-Power Functionality of the CY8CKIT-050 PSoC® 5LP Development Kit Guide. After this I was able to program the device as shown -

                  The Kit Guide just mentions that Reset mode is not supported as shown but this information is not clear. I will be raising an internal ticket to look into this.

                  Thank you for bringing this to our notice.



                  Rakshith M B


                  • 6. Re: miniprog3 problem

                    Hi Rakshith,


                    Thank you for replying, due to COVID-19, the solding of R30 instead of R23 take me time to get lab resource.


                    Latest phenomenon:

                    1)UI still crash after toggle power;

                    2)VDDA/VDDD ~20mV(after toggling operation) measured by multimeter;


                    UI below:


                    The Miniprog3 LED situation, the yellow one keeps on



                    Solding replacement


                    At last, I wonder if I can get the miniprog3 replaced by taobao.com(one of your official agents in China)since this product just bought back for several days.


                    Thank you for understanding!